lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-19-2013, 12:20 PM   #31
Not Yet Wild
 
Join Date: Jan 2013
Posts: 37
Default Re: Problems with my 98 ezgo

Ok update I took my cart to a service center and he told me he thought it was the controller.I put a controller in that I knew was good. It lights up and blinks green 4 times then blinks red alot. The paper that was with it gave me seven things to trouble shoot using the blinking red lights but it blinks more than 7 times. When you mash the pedal the light goes green but no movement.
mwilkey13 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-19-2013, 12:52 PM   #32
Gone Wild
E-Z-GO
 
Join Date: Mar 2011
Location: The hills of WV...
Posts: 315
Default Re: Problems with my 98 ezgo

I really doubt you are having a controller issue.. I am still thinking it is a connection problem. have you checked with johnnieb on this issue?
subby44 is offline   Reply With Quote
Unread 02-19-2013, 01:25 PM   #33
Not Yet Wild
 
Join Date: Jan 2013
Posts: 37
Default Re: Problems with my 98 ezgo

No I haven't checked with him.
mwilkey13 is offline   Reply With Quote
Unread 02-20-2013, 11:22 AM   #34
Astronautilator
 
Gonkulor's Avatar
E-Z-GO
 
Join Date: Sep 2011
Location: North Idaho
Posts: 1,494
Default Re: Problems with my 98 ezgo

I'll stick with my previous assessment. I'll bet a dollar you have a loose or bad connections in a terminal somewhere. It might be a pain to find it but a slow and methodical process of fingering through all your wiring connections will find the issue. Most likely you have a crimp connection that has corrosion in it or a majority of the strands int he connection have broken.

Because I question your electrical system. I'll be highly suspicious tossing parts at your cart will fix the problem. More often than not, it's the easy fix.
Gonkulor is offline   Reply With Quote
Unread 02-20-2013, 12:57 PM   #35
Gone Wild
E-Z-GO
 
Join Date: Mar 2011
Location: The hills of WV...
Posts: 315
Default Re: Problems with my 98 ezgo

I agree...
subby44 is offline   Reply With Quote
Unread 02-20-2013, 03:11 PM   #36
Not Yet Wild
 
Join Date: Jan 2013
Posts: 37
Default Re: Problems with my 98 ezgo

My other controller wouldn't light up or anything the new one at least does that much.
mwilkey13 is offline   Reply With Quote
Unread 02-20-2013, 05:40 PM   #37
Gone Wild
 
chloe's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Central Delaware
Posts: 858
Default Re: Problems with my 98 ezgo

That may be the point that narrows your search. Put the old controller back in and use a bit of dielectric grease on the connections. Clean all the contacts with some sandpaper or emory board before the grease. Don't forget the female part of the blade connectors. Post up what you have after that.
chloe is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
84 EZGO Problems Gas EZGO
Problems with EZGO TXT Gas EZGO
06 EZGO PDS problems Electric EZGO
97 EZGO problems please help Electric EZGO


All times are GMT -5. The time now is 09:19 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.