lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-21-2013, 09:46 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: north carolina
Posts: 59
Angry 90 ezgo getting 36 volt reading between hot to switch and load side

I have a 90 model ezgo. It was working fine last weekend. This weekend when I got on it and turned it on nothing happened. After looking the load side of switch to controls wire was broken/burnt off. Easy fix? But when I went to reattach it it blew Sparks out. I checked with meter and from line side of switch to load side it reads 38v. How is that? I checked for skinned place on wires and found nothing. I took wires loose trying to track down the issue and i'm just stumped. Please any advise or help would be great.
zroadrage is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-22-2013, 06:20 AM   #2
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 14,097
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

Welcome to BGW!

Is it a Resistor drive or a Electronic Speed Control drive?

Where exactly is is the switch with the wire burnt off, physically located?

The 38V means your 36V battery pack is about 95% charged.
A fully charged 36V battery pack reads 38.2V and if a 36V battery pack reads 36V, it is less than 50% charged.
JohnnieB is offline   Reply With Quote
Unread 07-22-2013, 08:14 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: north carolina
Posts: 59
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

the switch is the main key switch that turns on cart. the reading is actually 38.2v. it has resistor drive i think. it is a square box that looks like a power inverter. thanks for the reply.
zroadrage is offline   Reply With Quote
Unread 07-22-2013, 08:16 AM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: north carolina
Posts: 59
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

i dont understand why the load side of switch is reading negative. it goes to controls and limit switches. shouldnt it be no reading between these wires?
zroadrage is offline   Reply With Quote
Unread 07-22-2013, 08:46 AM   #5
BGW Sponsor
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 66,135
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

That is right, you have a short someplace. If there is a diode on the solenoid small posts this may have failed open? Seemed like you were on the right track trying to see where the short is coming from
scottyb is offline   Reply With Quote
Unread 07-22-2013, 09:15 AM   #6
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

Check your wiring harness everywhere it passes through the body and frame. The wire insulation tends to get rubbed through from vibration and just old age.
simple man is offline   Reply With Quote
Unread 07-22-2013, 09:21 AM   #7
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: north carolina
Posts: 59
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

If I remove the diode will should it clear short if that's the problem?
zroadrage is offline   Reply With Quote
Unread 07-22-2013, 09:27 AM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: north carolina
Posts: 59
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

The solenoid is new but could that be issue?
zroadrage is offline   Reply With Quote
Unread 07-22-2013, 10:20 AM   #9
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 14,097
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

Remove both the diode and resistor for the time being.
They are not needed for troubleshooting and getting the cart running, but should be reinstalled for normal operation.
(Their purpose is to reduce arcing on some of the contacts and prolong their service life.)

----
Installing the diode backwards, occasionally happens when a solenoid is replaced.

----------
I'm guessing, but it sounds like you have a Controller cart, so here is a schematic with the solenoid activation circuit highlighted.
Attached Images
File Type: jpg Marathon - Controller Schematic. with KSI traced.JPG (78.6 KB, 0 views)
JohnnieB is offline   Reply With Quote
Unread 07-22-2013, 10:36 AM   #10
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: north carolina
Posts: 59
Default Re: 90 ezgo getting 36 volt reading between hot to switch and load side

That's the right diagram for sure! If I remove the orange wire from the solenoid then that would clear the short if that is the problem correct?
zroadrage is offline   Reply With Quote
Reply

Tags
36v, grounding, switch
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
digital volt meter reading Electric EZGO
Volt reading when Isolating 2 6v batts, is seperate volt meter needed? Electric EZGO
Battery Reading is 32 volts on 48 volt system Electric Club Car
FYI..running volt reading Electric EZGO
New Batteries and Volt Reading HELP Electric Club Car


All times are GMT -5. The time now is 01:46 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.