lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-11-2013, 06:05 PM   #1
Not Yet Wild
 
Peachfuz's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: NE Indiana (DeKalb County)
Posts: 14
Default Cart suddenly stops 'going'

Over the weekend, my 95 EZGO medalist would quit 'going' mid-stream.

When I pressed the pedal, I could hear a clicking sound (possibly solenoid), but the cart would not go. I checked all cables and I checked the cable from charger port to switch,( I read somewhere about a safety wire on the charging port) there was a little crusty ness on a couple wires, I cleaned it off. It still would not go. I let the cart sit for a while, hopped on it, and drove it around and had no more issues.

The first time I hopped on it, my wife and daughter were on it for a little bit cruzin the campground.

Nothing smelled warm, nothing felt abnormally hot.

Anyone else experience this?
Peachfuz is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-11-2013, 06:36 PM   #2
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: Clinton Township, MI
Posts: 27
Default Re: Cart suddenly stops 'going'

I went through something similar to this with my cart. I have a 2001 Ezgo Txt series cart. It ended up being the I.T.S. (Inductive Throttle Sensor).
mathew21 is offline   Reply With Quote
Unread 08-11-2013, 06:42 PM   #3
Not Yet Wild
 
Peachfuz's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: NE Indiana (DeKalb County)
Posts: 14
Default

Ok, what does this handy I.T.S look like? Where can I locate it? Is there a 'true' way to test it?
Peachfuz is offline   Reply With Quote
Unread 08-11-2013, 06:52 PM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: Clinton Township, MI
Posts: 27
Default Re: Cart suddenly stops 'going'

Here's picture I took from the internet.




Here's a link of how to test it.
Inductive Throttle Sensor
mathew21 is offline   Reply With Quote
Unread 08-11-2013, 07:04 PM   #5
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 9,769
Default Re: Cart suddenly stops 'going'

Quote:
Originally Posted by Peachfuz View Post
Ok, what does this handy I.T.S look like? Where can I locate it? Is there a 'true' way to test it?
Inductive Throttle Sensor

the picture above is the coil, which is one part if the whole thing.

If you lift up your floor mat, you will see a small cover on the floor, its about 4" x 4" remove it, you will see a "black box" that is the entire ITS switch. inside the box is the coil, the plunger, and a limit switch.
Sir Nuke is offline   Reply With Quote
Unread 08-11-2013, 07:11 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2013
Location: Clinton Township, MI
Posts: 27
Default Re: Cart suddenly stops 'going'

Thanks for correcting me on my picture, A newbie trying to help out another newbie.
mathew21 is offline   Reply With Quote
Unread 08-11-2013, 10:01 PM   #7
Not Yet Wild
 
Peachfuz's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: NE Indiana (DeKalb County)
Posts: 14
Default

Thanks, I'll have a peek this weekend while at the campground.

I appreciate all of the shared knowledge here. I am new to the golf cart world, and I enjoy learning all about it. :)
Peachfuz is offline   Reply With Quote
Unread 08-12-2013, 06:47 AM   #8
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 14,410
Default Re: Cart suddenly stops 'going'

A few corrections.

ITS = Inductive Throttle System
The box under the floor mat is the "Pedal Box"
The microswitch in the Pedal Box (MS-3) is part of the solenoid activation circuit rather than the ITS.
The mechanically moved plunger and ITS sensor are just the external portion of the ITS, the rest is inside the controller.
Also, the same sensor is used by different controllers, but different controllers have different ITS specs, so you have to know which make and model controller it is connected to, to verify it's proper operation.
JohnnieB is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
cart suddenly losing power Electric Club Car
09 RXV Suddenly Stops Electric EZGO
05 precedent stops suddenly then starts working again Electric Club Car
2004 Suddenly stops Electric EZGO
Cart Just Suddenly Stops Running! Electric Club Car


All times are GMT -5. The time now is 03:37 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.