lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-12-2013, 07:39 PM   #1
Not Yet Wild
 
Join Date: Jul 2013
Posts: 47
Default Ezgo series Alltrax SPM 48500 question/problem

Sent a message to Scotty but don't know how much he checks the forum on weekends so thought may some of y'all might have some suggestions as well. Just installed HD switch, solenoid and the SPM controller and went to drive the cart and it drives exactly how it did stock. No extra snap at take off and slows to a crawl going up a hill. It's like I didn't do anything to it. What would cause this? Bad controller? Settings not right? I'm new to these controllers but am sure it should show at least some improvement. Any ideas as to what the issue could be?
Taylor1595 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-12-2013, 08:08 PM   #2
Gone Wild
 
mike777's Avatar
E-Z-GO
 
Join Date: Jul 2013
Location: MinneSNOWta
Posts: 238
Default Re: Ezgo series Alltrax SPM 48500 question/problem

Quote:
Originally Posted by Taylor1595 View Post
Sent a message to Scotty but don't know how much he checks the forum on weekends so thought may some of y'all might have some suggestions as well. Just installed HD switch, solenoid and the SPM controller and went to drive the cart and it drives exactly how it did stock. No extra snap at take off and slows to a crawl going up a hill. It's like I didn't do anything to it. What would cause this? Bad controller? Settings not right? I'm new to these controllers but am sure it should show at least some improvement. Any ideas as to what the issue could be?
what kind of shape are your batts in? how old??
mike777 is offline   Reply With Quote
Unread 10-12-2013, 08:09 PM   #3
Not Yet Wild
 
Join Date: Jul 2013
Posts: 47
Default Re: Ezgo series Alltrax SPM 48500 question/problem

2 month old batteries.
Taylor1595 is offline   Reply With Quote
Unread 10-12-2013, 08:31 PM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 63,851
Default Re: Ezgo series Alltrax SPM 48500 question/problem

what batteries? and what does the pack voltage drop to when the cart slows down?
scottyb is offline   Reply With Quote
Unread 10-12-2013, 08:51 PM   #5
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 6,286
Default Re: Ezgo series Alltrax SPM 48500 question/problem

Quote:
Originally Posted by Taylor1595 View Post
Sent a message to Scotty but don't know how much he checks the forum on weekends
Poor dude obviously works nearly 24/7/365.25
yurtle is offline   Reply With Quote
Unread 10-12-2013, 08:58 PM   #6
Not Yet Wild
 
Join Date: Jul 2013
Posts: 47
Default Re: Ezgo series Alltrax SPM 48500 question/problem

Looks like he does. Sent u another message Scotty
Taylor1595 is offline   Reply With Quote
Unread 10-12-2013, 09:04 PM   #7
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 6,286
Default Re: Ezgo series Alltrax SPM 48500 question/problem

Just 'cause I give him an 'at a boy don't mean ya gotta abuse it.
yurtle is offline   Reply With Quote
Unread 10-13-2013, 07:13 AM   #8
Gone Wild
 
azTony's Avatar
E-Z-GO
 
Join Date: Jan 2013
Location: Sun Lakes, Arizona
Posts: 546
Default Re: Ezgo series Alltrax SPM 48500 question/problem

I bought the same package from Scotty a while back and had a similar situation where it just crawled up the hills and moved normal. Ended up being the settings.
azTony is offline   Reply With Quote
Unread 10-13-2013, 08:53 AM   #9
Not Yet Wild
 
Join Date: Jul 2013
Posts: 47
Default Re: Ezgo series Alltrax SPM 48500 question/problem

Quote:
Originally Posted by azTony View Post
I bought the same package from Scotty a while back and had a similar situation where it just crawled up the hills and moved normal. Ended up being the settings.
What settings did you have to change? I haven't hooked it up to the computer yet.
Taylor1595 is offline   Reply With Quote
Unread 10-13-2013, 11:36 AM   #10
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 7,975
Default Re: Ezgo series Alltrax SPM 48500 question/problem

taylor.....are you still running a stock motor?
Sir Nuke is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2004 EZGO TXT Electric Series Drive Problem with Forward Electric EZGO
Alltrax SPM-48500 New Golf Carts and Parts
Mounting Alltrax SPM-48500 to 2001.5+ ezgo series txt Electric EZGO
Alltrax 500 amp controller help for EZGO series TXT Electric EZGO
I have a question about my 98' EZGO TXT Series Cart Electric EZGO


All times are GMT -5. The time now is 01:09 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.