lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-05-2008, 06:05 PM   #1
Not Yet Wild
 
Join Date: Oct 2008
Posts: 7
Default My baby broke

98 E Z Go, electric. Worked fine and then stopped. The solenoid will click when pedel is pushed down. No forward, reverse or anything. I checked the cables and connections and they seem to be ok. I charged the batteries last night and the meter shows that are fullly charged. I just came in from looking at it again and when I felt the solenoid, the bottom is very hot with the key turned off. It is a series cart, used to take the dogs riding in and hauling tree limbs. It is about 60 miles to the closest repair place as East Texas is not exactly a hot bed for golf carts. The batteries need replacing I know, but the they seem to take a charge. All help and advise appreciated. Thanks Wes
wes1945 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-05-2008, 06:26 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: My baby broke

1st thing is voltage readings from each battery and than load test............
shadowman is offline   Reply With Quote
Unread 10-05-2008, 06:35 PM   #3
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: My baby broke

Welcome to the forum wes1945..................
rusty is offline   Reply With Quote
Unread 10-05-2008, 06:51 PM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,085
Default Re: My baby broke

Yeah guys but, solenoid should NOT be hot to touch sitting there? Give it the Ole East Texas jump test...Use a short heavy wire( Cable ) and make a jumper across the two large terminals on the solenoid. If the cart runs go to town when you get a chance and buy a solenoid of the voltage needed to match your cart/charger...
scottyb is online now   Reply With Quote
Unread 10-05-2008, 07:52 PM   #5
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,412
Default Re: My baby broke

Selonoid is hot sitting there with key off. Something is telling the selonoid to stay engaged or it failed in the open condition which is good. If it had fail in the closed position the cart would be moving on it own with the key off and it in Forward or reverse. You would have to keep putting it in nuetral to stop it. Do as stated above with jumper cable to the 2 big terminals on selonoid and see it it will run.
Andy4639 is offline   Reply With Quote
Unread 10-05-2008, 07:53 PM   #6
Not Yet Wild
 
Join Date: Oct 2008
Posts: 7
Default Re: My baby broke

Thanks guys, I will try the jumper, hope it works and all is wrong is the solenoid. If that is not it, then I will try the load test. If thats not it, I will be back. Thanks again Wes
wes1945 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Harley Golfcart Broke >>>> Help !!!! Gas Harley Davidson
broke rod today Gas EZGO
im having a baby Gas Yamaha
Broke something again!!!!! Lifted Golf Carts
Oh No!!! My Baby!!! Gas EZGO


All times are GMT -5. The time now is 12:45 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.