lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-11-2014, 12:02 AM   #1
Not Yet Wild
 
Join Date: Apr 2014
Posts: 18
Unhappy Cable going to motor just fried.

Got a problem. Just bought a cart. 1986 Marathon. Put new batteries in the cart and it ran great for a while. Then all of a sudden I saw a spark at the moter after pressing the gas pedal and checked the motor. One of the cables to the motor fried and broke off. Did I fry the motor? I'm not where to start. Totally new to carts. Any help would be appreciated! Thanks in advance.
paulvedderjr is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-11-2014, 03:14 AM   #2
Gone Wild
E-Z-GO
 
Join Date: Jan 2014
Location: South Georgia
Posts: 993
Default Re: Cable going to motor just fried.

Sounds like a loose connection may have caused the cable end to get hot at the motor connection assuming the rest of the cable is ok. Motor may be ok. Give it a little closer inspection. How far back did the cable get hot? Golf carts draw a lot of current when operating and a bad connection can get very hot. Some of the more experienced forum members will help you in the morning.
radioman is offline   Reply With Quote
Unread 04-11-2014, 08:58 AM   #3
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,626
Default Re: Cable going to motor just fried.

That's about it -in a nutshell. If the Marathon has the original 6g cables in it ( most of them do) Then it will benefit from a complete new set of 4g cables. Old cables build resistance over the years. The resistance causes heat.
scottyb is offline   Reply With Quote
Unread 04-11-2014, 10:27 AM   #4
Not Yet Wild
 
Join Date: Apr 2014
Posts: 18
Default Re: Cable going to motor just fried.

Here is the damage. I guess I need to test out the motor now. Any thoughts?
Attached Images
File Type: jpg IMG_20140411_102526.jpg (69.1 KB, 0 views)
paulvedderjr is offline   Reply With Quote
Unread 04-11-2014, 10:33 AM   #5
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,626
Default Re: Cable going to motor just fried.

Tag and remove all 4 cables then check for unwanted continuity between any A and any S terminals
scottyb is offline   Reply With Quote
Unread 04-11-2014, 11:05 AM   #6
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: Cable going to motor just fried.

Assuming the motor checks out OK, It's hard to tell from the pic, but that stud may need replacing. Either you can do it, or probably any motor shop can do it.
yurtle is offline   Reply With Quote
Unread 04-11-2014, 11:42 AM   #7
Not Yet Wild
 
Join Date: Apr 2014
Posts: 18
Default Re: Cable going to motor just fried.

Quote:
Originally Posted by scottyb View Post
Tag and remove all 4 cables then check for unwanted continuity between any A and any S terminals
How do I check for that? I just removed the motor. That terminal is loose and pretty busted.
Attached Images
File Type: jpg IMG_20140411_112755.jpg (98.7 KB, 0 views)
paulvedderjr is offline   Reply With Quote
Unread 04-11-2014, 11:43 AM   #8
Not Yet Wild
 
Join Date: Apr 2014
Posts: 18
Default Re: Cable going to motor just fried.

Quote:
Originally Posted by yurtle View Post
Assuming the motor checks out OK, It's hard to tell from the pic, but that stud may need replacing. Either you can do it, or probably any motor shop can do it.
This motor is so old. You think its worth changing out that stud?
paulvedderjr is offline   Reply With Quote
Unread 04-11-2014, 11:54 AM   #9
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,626
Default Re: Cable going to motor just fried.

Send that motor to PQ for a bandit rebuild
scottyb is offline   Reply With Quote
Unread 04-11-2014, 11:58 AM   #10
Not Yet Wild
 
Join Date: Apr 2014
Posts: 18
Default Re: Cable going to motor just fried.

Quote:
Originally Posted by scottyb View Post
Send that motor to PQ for a bandit rebuild
Sorry, total newbie to these forums. I have NO idea what that means!
paulvedderjr is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric EZ-GO F/R Fried Motor (for sale?) Electric EZGO
2007 PDS motor fried Electric EZGO
Motor or Controller Fried Electric Club Car
Fried Motor? Electric Club Car
Battery Cable To Motor Electric EZGO


All times are GMT -5. The time now is 05:06 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.