lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-16-2008, 10:44 PM   #11
Not Yet Wild
 
Join Date: Oct 2008
Posts: 9
Default Re: 1994 EZ-GO Medalist will not move

Does anyone think that overheating of the solenoid then condensation on the case could cause the rusting like that seen in the photo? That's the only thing I can come up with. It's really odd.
bobmc32 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-16-2008, 10:52 PM   #12
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 1994 EZ-GO Medalist will not move

yessir...... or sust salty air from a coastal region will do it too, but if thats the case, there will be substantial rust on other parts of the frame & such.
rusty is offline   Reply With Quote
Unread 10-21-2008, 11:46 PM   #13
Not Yet Wild
 
Join Date: Oct 2008
Posts: 9
Default Re: 1994 EZ-GO Medalist will not move

Well, I live a couple hundred miles inland from the Gulf so not salt corrosion. I just noticed today that on the speed controller, which has four post, the second post from the right has two connectors and one of the two has been clipped by wirecutters. Same for the right big post on the solenoid. I didn't do this and this should not be the reason for the recent "no go" of the cart I wouldn't think. Is that post on the controller supposed to have two connectors and same for the right big post on the solenoid? I am currently at a standstill. (I did replace the solenoid and no change - no solenoid click when jumping small post and no action when jumping the large post.)
bobmc32 is offline   Reply With Quote
Unread 10-22-2008, 05:53 PM   #14
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1994 EZ-GO Medalist will not move

i would look at eitherv the F&r switch and micros or with what you sid about controller if its stock there should be a post missing or clipped.......now a replacement would only have 3 studs they eliminated one but stock should be 4 what brand controller?....................................
shadowman is offline   Reply With Quote
Unread 10-22-2008, 07:55 PM   #15
Not Yet Wild
 
Join Date: Oct 2008
Posts: 9
Default Re: 1994 EZ-GO Medalist will not move

Thanks shadowman for the input. My terminology is not helping most likely. I was calling wires connectors. I don't know the brand controller as yet but I feel sure it's original as I kind of know the first two owners. The controller has four posts. The two outside post have one wire to each, the left inside post has two wires and the right inside post has one wire altho it has a clipped wire under the nut also as does the right big post on the solenoid.
I did disconnect the accelerator microswitch and jump it but that seems to not be the problem. I will search for ways to test the F/R switch.
bobmc32 is offline   Reply With Quote
Unread 10-22-2008, 11:11 PM   #16
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1994 EZ-GO Medalist will not move

i should have said the stock controller should have 4 studs not 3 the aftermarket will have 3 as they eliminated one on the stock controller the b- should have a cable going to a battery and one going to the F&R switch b+ should go to the motor a2 should go to the motor and one to the F&R switch and m- to a battery, now this is an older controller cart version and my diagram isn,t the greatest so double check but your stock controller should have 4 studs coming off of it and all are used without any wires cut off..............so i was wrong in my above popst and i,m sorry and if what your saying is your stock controller only has 3 studs and a cable cut than your problem in there somewhere......anyway you can take a pic and post it?........................................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1994 club car needs TLC Electric Club Car
1994 Ezgo Medalist Electric EZGO
EZ-GO 1994 medalist Electric EZGO
1994 or 1994.5? What do I have Gas EZGO
1994 Medalist with a need for speed Electric EZGO


All times are GMT -5. The time now is 10:53 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.