lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-15-2014, 09:59 PM   #1
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 567
Default Squeal on drivers side rear wheel, options .

I have a squeal from the left rear driver s side. Cart is 2007 txt. I replaced wheels an tires and had 1" spacers for 2 years. Trying to match Jake's long travel front. Put 2 in spacers on and the squeal started after a few miles. Brakes no squeal they are auscos, axles, spacers etc lubed, no change. Put 1" spacers back on it quieted it for short time. But its back and getting louder. It is when going forward and noticeable if pushed no one aboard and worse at low speed barely moving loaded 1 person. Only thing not done was castle nut tighten, I did check it but not tighten. By the way with wheel off can I jack stand that side and lower the other wheel to torque the but. Any help is appreciated.
beach cart is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-16-2014, 07:17 AM   #2
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 9,448
Default Re: Squeal on drivers side rear wheel, options .

Quote:
Originally Posted by beach cart View Post
I have a squeal from the left rear driver s side. Cart is 2007 txt. I replaced wheels an tires and had 1" spacers for 2 years. Trying to match Jake's long travel front. Put 2 in spacers on and the squeal started after a few miles. Brakes no squeal they are auscos, axles, spacers etc lubed, no change. Put 1" spacers back on it quieted it for short time. But its back and getting louder. It is when going forward and noticeable if pushed no one aboard and worse at low speed barely moving loaded 1 person. Only thing not done was castle nut tighten, I did check it but not tighten. By the way with wheel off can I jack stand that side and lower the other wheel to torque the but. Any help is appreciated.
if your brakes are properly adjusted, just set the brake and torque the nut. shouldn't be a problem.
Sir Nuke is offline   Reply With Quote
Unread 06-16-2014, 09:24 AM   #3
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 567
Default

Thanks

Sent from my Torque using Tapatalk
beach cart is offline   Reply With Quote
Unread 06-16-2014, 12:56 PM   #4
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 567
Default

Drivers side wheel bearing is culprit, both sides will be replaced.

Sent from my Torque using Tapatalk
beach cart is offline   Reply With Quote
Unread 06-19-2014, 06:41 PM   #5
Getting Wild
 
suffolklou's Avatar
E-Z-GO
 
Join Date: Aug 2012
Posts: 87
Default

Did the bearings fix your problem?
suffolklou is offline   Reply With Quote
Unread 06-19-2014, 07:13 PM   #6
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 567
Default

Bearings for sure fixed the problem, they were changed yesterday. Strange though the squeal sounded like a rubber sqeak not grinding like all the other bearings I have ever changed. For a course 2007 cart thats had so much weight added and completely upgraded, these dana rear ends are pretty tough.
beach cart is offline   Reply With Quote
Unread 06-19-2014, 08:33 PM   #7
Getting Wild
 
suffolklou's Avatar
E-Z-GO
 
Join Date: Aug 2012
Posts: 87
Default

I ordered new bearings for mine. Gonna tackle it next week. Did you change the seal or just the bearings?
suffolklou is offline   Reply With Quote
Unread 06-19-2014, 08:34 PM   #8
Getting Wild
 
suffolklou's Avatar
E-Z-GO
 
Join Date: Aug 2012
Posts: 87
Default

The squeaking on mine also sounds like rubber.
suffolklou is offline   Reply With Quote
Unread 06-19-2014, 08:46 PM   #9
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 567
Default

It could be something different on yours but I was sure at first it was shock mounts or the springs or bushings, but quiet again with new bearings.
beach cart is offline   Reply With Quote
Unread 06-19-2014, 08:49 PM   #10
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 567
Default

LoL, while I was having that done had new brake pads put on my Ausco disc brakes, sliders are squeaking, I know how to fix this, a little lithium will fix that tomorrow.
beach cart is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Drivers side back wheel noise?? Electric EZGO
drivers side axle needed Electric Club Car
Rear driver side wheel squeek Gas EZGO
Drivers Side Sag Electric EZGO


All times are GMT -5. The time now is 02:51 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.