Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (http://www.buggiesgonewild.com/)
-   Electric EZGO (http://www.buggiesgonewild.com/electric-ezgo/)
-   -   Wiring question for 98 EZ GO (http://www.buggiesgonewild.com/electric-ezgo/9536-wiring-question-98-ez-go.html)

Gibbs 10-23-2008 07:33 AM

Wiring question for 98 EZ GO
I recently purchased a used 98 ez go cart. The only wires "un-hooked" when I received it were the positive, negative, and red wire out of the charger receiver as well as all of the batteries.

I have put the batteries back in correctly and they all have voltage, and I connected the red wire from the charger receiver back to the correct micro switch terminal. All other wires have voltage and so does the solenoid.

Here are my issues:

When I put the cart in forward the horn sounds but the cart does not move in either direction however.

The cart will not charge. I have tried my charger, and a friends charger that I know works, both over night and it will not accept a charge.

Does anyone have any suggestions? This is my first cart so I am lost. I do know there is no run/tow switch on this model so does that mean it is not DCS?. And the cart worked fine before the batteries and charger receiver were un-hooked. I bought it from a friend so I know everything was sound.

Sorry for the long post but I would appreciate any help anyone has to offer.

Thank you.

Texasworkhorse 10-23-2008 12:40 PM

Re: Wiring question for 98 EZ GO
Have you used the wiring diagraphms in the stickies at the top of the forums to ENSURE that all wiring is correct? Majority of electrical problems seen on here have to do with poor wiring/wrong wiring. Let us know.

Pics are always welcome

shadowman 10-23-2008 01:03 PM

Re: Wiring question for 98 EZ GO
yes go over all battery cable connections, the easiest way to put this is if you take the front battery out before you took it out the pos terminal was closest to the front of the cart and neg terminal towards rear.......now you drop a new battery in and without thinking you put it in with the neg terminal towards front and pos towards rear and you end up putting a pos wire where a neg wire should be............... its then really easy to miswire the batteries or a few on them.........beleive it or not i see this alot so you really have to pay attention to what terminal on battery was in what location...................if your not sure there should be a diagram in the stickies if you can,t find it let me know i should have one........................................8)

Gibbs 10-24-2008 08:05 AM

Re: Wiring question for 98 EZ GO
I got it fixed. One battery had nearly drained between charging it and installing it which put the overall voltage below 28v. That is why the charger would not work. I appreciate your responses and it's running like a champ now!

Thanks again

All times are GMT -5. The time now is 07:12 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.