lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-28-2008, 09:12 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2008
Location: howell nj
Posts: 11
Default 94 medalist electric problem

I hope some one can help me...I just purchased a 94 medalist with new batteries and it wont move...I checked voltage at key switch and f and r switch, both sides of solinoid and I have 36 volts all around...I pulled motor out and gave to local dealer to bench check and they said it was fine.. I reinstalled and kept checking.... I have the wrong manual but alot of the stuff is still the same....The little studs on solinoid has 36 volts on one side only but manual said it should have on both but not sure...Either way It doesnt make any noise...but voltage on both large terminals...anyone have any ideas.. thanks
crunchfish is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-28-2008, 09:19 PM   #2
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 25,039
Default Re: 94 medalist electric problem

Does the reverse buzzer still work?
gornoman is online now   Reply With Quote
Unread 10-28-2008, 09:24 PM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2008
Location: howell nj
Posts: 11
Default Re: 94 medalist electric problem

it was disconnected..The ground wire to the micro switch was taped off..I jumped it and when in reverse the alarm stayed constant on..Really loud ,,,i then broke the connection of ground to turn it off..
crunchfish is offline   Reply With Quote
Unread 10-29-2008, 04:16 PM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2008
Location: howell nj
Posts: 11
Default Re: 94 marathon electric problem

sorry its a marathon and I have full 36 volts at the motor..some one please help? thanks
crunchfish is offline   Reply With Quote
Unread 10-29-2008, 04:38 PM   #5
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 94 medalist electric problem

does the solenoid ckick when you hit gas pedal? if not jack the rear up get wheels off ground if you don,t have a run tow switch get a peice of 6 gage cable turn key on and put cart in gear and jump the large post on solenoid you might get some sparkage so be ready and don,t crap in your shorts.........slowley press pedal down if wheels start spinning than replace solenoid, diode and resistor and drive it away...............if you F&R lever is by your legs also make sure that the double wide micro switch with the metal arm coming off of it didn,t bend or roll over thats a common problem............another thing if your getting just 36 volts thats a dead set of batteriesyou should be more in the area of 39 volts or better.........your sure cables are all on right and battery terminals are clean and tight? pull tug and twist to make sure..........i don,t know if the 94 has a run tow switch but if it does it is in the run position right? we spent days trying to help a fellow whos cart wouldn,t do anything and here he forgot to put it bacik in run position ..........never overlook the little things...........................
shadowman is offline   Reply With Quote
Unread 10-29-2008, 04:59 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2008
Location: howell nj
Posts: 11
Default Re: 94 medalist electric problem

thanks for the response, both sides of solenoid have full voltage and I checked that micro switch it seemed to be working...I did a ohms test on it and it opened and closed as I moved the lever..On solenoid small terminal with red wire gets voltage when i step on gas pedal so I believe speed controller is good to..Solenoid does not click at all but when switch is turned on voltage is there...No run switch on this model,,,im still trying to find manual with troubleshoot in it,,,,ive found previous and newer models my luck but will keep trying...thanks again
crunchfish is offline   Reply With Quote
Unread 10-29-2008, 11:44 PM   #7
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 94 medalist electric problem

Welcome to the forum crunchfish....................
rusty is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Anoter electric problem Electric EZGO
1995 EZGO electric Medalist won't go Electric EZGO
Yamaha Gas -Electric Problem? Gas Yamaha
1995 EZ-Go Medalist Differential Problem Electric EZGO
electric ez go problem Electric EZGO


All times are GMT -5. The time now is 12:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.