lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-28-2015, 02:22 PM   #1
Not Yet Wild
 
Join Date: Mar 2015
Posts: 2
Default G19E only goes when pedal depressed slightly ??

Hi all, new to golf cart forum, as I am new to owning a golf cart. I appreciate any help in advance. Bought a 1999 G19E 48V for the family Christmas 2014. Seller has 1 year old batteries - volt meter registers great on all 6. Cart died a couple times during test drive, he goes to store gets a new "on/off" switch, works like magic. Bring it home, works great.....then....all the sudden while crusing or just starting for first time or completely randomly, the cart will not move while the accel pedal is fully depressed. back off the throttle all the way and ease into it and I mean ease into it and about 1/8 of the full depress, you'll hear the motor start winding and poof! - max power.....until you move your move even 1/2 inch more or less on the pedal, dies again. Local golf cart guy couldn't get it to 'break' while he had it. apparently it only happens when I drive it. Help, thoughts, suggestions?
JFryG19E is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-13-2015, 09:02 AM   #2
Not Yet Wild
 
Join Date: Mar 2015
Posts: 2
Default Re: G19E only goes when pedal depressed slightly ??

Thanks to HiTechRedNeck - who happens to live 5 miles from me, the problem appears to be fixed. Changed out the solenoid, cleaned up the connections, etc. - cart hasn't failed yet.

If any of you want HiTechRedNeck's autograph with a picture, just let me know, i'll make it happen.
JFryG19E is offline   Reply With Quote
Unread 04-15-2015, 02:52 PM   #3
Gone Wild
 
Join Date: Aug 2014
Location: Duncan Corners
Posts: 905
Default Re: G19E only goes when pedal depressed slightly ??

Thanks for the Thumbs up !!!

No pics --- Too ugly---
HiTechRedNeck is offline   Reply With Quote
Unread 04-16-2015, 03:32 PM   #4
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,926
Default Re: G19E only goes when pedal depressed slightly ??

Glad to hear things worked out so nicely. It's great when a local member can help out! I have helped several neighbors with their carts here in Rio Verde. I expect that I may get more requests as word gets around.
Volt_Ampere is offline   Reply With Quote
Unread 04-16-2015, 07:15 PM   #5
Gone Wild
 
Join Date: Aug 2014
Location: Duncan Corners
Posts: 905
Default Re: G19E only goes when pedal depressed slightly ??

Full disclosure...

I work for a shop here and JFry brought cart in for repair.

Problem was intermittent and hard to pin down.

I believe he was charged a fair price -- Spent more time chasing intermittent
than he was billed for. ( They are the worst problems)

Again thanks For the Thumbs up !!!
Glad to hear cart is doing well !!!!
HiTechRedNeck is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
When slightly depressing gas pedal motor is at full speed Electric EZGO
'10 EZGO ST Gas Pedal Depressed and Nothing Happens Gas EZGO
Starter motor no go when gas pedal depressed Gas Club Car
Won't start when gas pedal depressed Gas Yamaha
G2 electric lags with pedal depressed Electric Yamaha


All times are GMT -5. The time now is 10:22 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.