lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-18-2009, 12:03 AM   #1
Not Yet Wild
Yamaha
 
Join Date: Mar 2009
Location: south louisiana
Posts: 8
Unhappy G1 very sluggish

I recently picked up a g1 electric cart for the local golf course and it was preforming fine until a week ago. It will roll fine till about 50 yards and gets very sluggish to the point where it is barely moving. If it sits a couple minutes it will do the same. This is what I checked so for:

-Batteries are alittle over a year old and old are showing 6.5 volts (checked individually)
-All cables were changed with batteries and were cleaned along with battery posts
-Changed 2 cables that were questionable going to motor and solinoid.

Now I need some direction into troubleshooting the speed controller and resistor coil or ....can there be another problem. I hope its not much because not what to dump a bunch of money into old cart. Thanks for any direction in advance.

Clint
duprec is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-18-2009, 12:24 AM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: G1 very sluggish

Hello duprec and Welcome to the forum.
rusty is offline   Reply With Quote
Unread 03-18-2009, 12:29 AM   #3
Gone Wild
 
dirtysouth's Avatar
Club Car
 
Join Date: Feb 2009
Location: P-COLA
Posts: 1,176
Smile Re: G1 very sluggish

Quote:
Originally Posted by duprec View Post
I recently picked up a g1 electric cart for the local golf course and it was preforming fine until a week ago. It will roll fine till about 50 yards and gets very sluggish to the point where it is barely moving. If it sits a couple minutes it will do the same. This is what I checked so for:

-Batteries are alittle over a year old and old are showing 6.5 volts (checked individually)
-All cables were changed with batteries and were cleaned along with battery posts
-Changed 2 cables that were questionable going to motor and solinoid.

Now I need some direction into troubleshooting the speed controller and resistor coil or ....can there be another problem. I hope its not much because not what to dump a bunch of money into old cart. Thanks for any direction in advance.

Clint
Welcome duprec, G1's are old carts, but bullet proof. Someone will be along soon enough to answer your question. Good Luck. Enjoy the forum.
dirtysouth is offline   Reply With Quote
Unread 03-18-2009, 08:08 PM   #4
Not Yet Wild
Yamaha
 
Join Date: Mar 2009
Location: south louisiana
Posts: 8
Default Re: G1 very sluggish

I checked the voltage out of speed controller and it was fine, the voltage to the motor is fine. The cart seems to run fine when the tires are lifted off off ground. After running cart about 30 yards it felt like it lost all power and the voltage to motor was still good but the motor was smoking alittle and was alittle hot. What do you guys think?
duprec is offline   Reply With Quote
Unread 03-25-2009, 07:09 PM   #5
Gone Wild
 
dougmcp's Avatar
 
Join Date: Mar 2009
Location: Roseville, CA
Posts: 2,757
Default Re: G1 very sluggish

Just a guess, sounds like the motor brushes are not making good contact.
dougmcp is offline   Reply With Quote
Unread 03-25-2009, 09:36 PM   #6
Not Yet Wild
Yamaha
 
Join Date: Mar 2009
Location: south louisiana
Posts: 8
Default Re: G1 very sluggish

Yeah thatís I was thinking so I pulled the plastic covers by the brushes and there was a lot of black dust and some metal pieces fall out. I pushed the accelerator and I could see sparks in the motor so I figured that was the problem and I was not going to put more money into that cart. I had a friend that needed a couple parts so I gave him what he needed an I will use his cart at the course. The rest of my junk is sitting in a salvage yard. (RIP)
duprec is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
92 Marathon sluggish and backfires Gas EZGO
Sluggish Cart Electric Club Car
Sluggish Electric Club Car
Sluggish and chattering cart Electric EZGO


All times are GMT -5. The time now is 06:05 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.