lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-14-2018, 06:24 PM   #1
Not Yet Wild
 
Join Date: Apr 2018
Posts: 4
Default G19 climbs well in reverse but stalls in forward

1998 Yamaha G19 with new batteries and lots of power is occasionally losing power (only a second or less at a time - feels like I tapped the brake) while driving at normal speed. I may drive a couple of miles without this happening. One time after several of these hesitations it slowly lost power completely and died. I came back to it a couple of hours later and started poking around. I toggled the Run/Tow switch and tried the accelerator again. It worked, and I drove home without a problem.

Since then it hasn't died completely, but it still hesitates occasionally at full speed and at slow speeds it doesn't want to climb - in forward - at least not consistently. It will stall out. Depending on the hill, I may be able to push with my left leg and it may start rolling fast enough to regain power. Seems to have NO problem climbing with power in reverse.

Diagnosis?
sgwriter is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-15-2018, 12:36 AM   #2
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 10,553
Default Re: G19 climbs well in reverse but stalls in forward

Likely batteries. Get us pack voltage when the failure happens. You can carefully stick your meter probes in the charge port to get a reading while driving.
cgtech is offline   Reply With Quote
Unread 04-15-2018, 11:49 AM   #3
Not Yet Wild
 
Join Date: Apr 2018
Posts: 4
Default Re: G19 climbs well in reverse but stalls in forward

Thanks for the reply, cgtech.

Pardon my ignorance, but wouldn't it take as much battery power to climb in reverse as it would in forward?

If it is battery related -- and they are fairly new -- would the symptoms suggest a poor connection somewhere? Maybe a loose one that would make the problem intermittent? If so, where would you suspect? I've cleaned the main posts going from the batteries.

Thanks.
sgwriter is offline   Reply With Quote
Unread 04-15-2018, 01:34 PM   #4
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 10,553
Default Re: G19 climbs well in reverse but stalls in forward

The controller operates in "limited max power/speed" mode in reverse. This reduces the demands on the power source.
cgtech is offline   Reply With Quote
Unread 04-15-2018, 09:04 PM   #5
Not Yet Wild
 
Join Date: Apr 2018
Posts: 4
Default Re: G19 climbs well in reverse but stalls in forward

Thanks. I'm new at all of this. I'll look into getting a voltage meter and figuring out what, when, and where to test. As well as what the readings indicate . . .
sgwriter is offline   Reply With Quote
Unread 04-19-2018, 10:38 AM   #6
Not Yet Wild
 
Join Date: Apr 2018
Posts: 4
Default Re: G19 climbs well in reverse but stalls in forward

One additional piece of info. The climbing problem FEELS like a torque problem, like trying to make a car start in third gear -- from a dead stop -- and go uphill. Sometimes it will find the right "gear" and climb without a problem; sometimes it won't. But it has never failed to climb in reverse.

I'm never out long enough to let the battery power indicator fall below the halfway mark. It rarely gets below 70% before recharging fully.
sgwriter is offline   Reply With Quote
Unread 04-21-2018, 02:45 AM   #7
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 10,553
Default Re: G19 climbs well in reverse but stalls in forward

Still need voltages. I never base anything on the readings of the "10-led bar graph meter". Those meters are only ~ ("air-quotes accurate") accurate on a perfect battery pack, not worth a thing on a worn out pack, or one with a individual failing battery.
cgtech is offline   Reply With Quote
Reply

Tags
brief hitches in cruise
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Forward/Reverse, drives forward then jumps in reverse Electric EZGO
2006 ezgo forward is reverse and reverse is forward please help Electric EZGO
Reverse alarm sounds in Forward, wont go forward or reverse Electric Club Car
Forward Reverse switch melted on forward...have question about replacement part Electric Club Car
2005 EZGO TXT stalls out in forward but not reverse Electric EZGO


All times are GMT -5. The time now is 11:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.