lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-26-2019, 08:46 PM   #1
Not Yet Wild
 
Join Date: Jan 2019
Posts: 3
Default 1999 G19E Won't suddenly will not run

I got my Yamaha G19e out on a hill the other day, it was snowy and I ended up getting stuck and running the batteries almost completely dead.

I was working it pretty hard trying to get up the hill and eventually the batteries began to get very low and it just stopped running.

I assumed the batteries being that low caused the unit to "power down" or I'd gotten something hot that needed to cool down.

Anyway, now it's charged completely but it won't move;

1) back up alarm works
2) it does the solenoid click if I push it (think I've heard it called that)
3) The main fuse is fine

I had a similar issue in the past after towing it and forgetting to put the unit in tow.
I believe it was fixed by pulling the battery power and flipping the
tow/drive switch a few times and it reset. Is that the correct method?

Anyway, I've done that, no dice...

I'm not sure what I might try next, cart has always worked perfectly
and I am sure this is related to the abuse it got on the hill.

Any ideas what I might try?

I use this thing every day and would like to get it sorted.

Thanks all!
bigmark1972 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-28-2019, 08:35 AM   #2
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,569
Default Re: 1999 G19E Won't suddenly will not run

Maybe pulled a wire loose when stuck on the hill?
cgtech is offline   Reply With Quote
Unread 01-31-2019, 03:27 PM   #3
Not Yet Wild
 
Join Date: Jan 2019
Posts: 3
Default Re: 1999 G19E Won't suddenly will not run

Thanks for the reply, I will look more closely.

It was relatively free of anything that would snag a wire where I got stuck with gravel under the snow.

The way it acted I'd expect to find another fuse or overload somewhere but not seeing anything else on the schematic.

I'm going to tow it into my pole barn tonight and have a closer look. It's a zillion below zero here in Michigan right now.
bigmark1972 is offline   Reply With Quote
Unread 01-31-2019, 06:02 PM   #4
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 7,534
Default Re: 1999 G19E Won't suddenly will not run

Bigmark, cgtech knows 1000 times more than I do about these. But I had one and my neighbor has one. Maybe it's just coincidence, but for some reason it seems like they go through run/tow switches. Just a switch, check it out.
Mooncarter is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
1999 Yamaha G19E solenoid stays closed always Electric Yamaha
1999 DS -- Suddenly Slow Electric Club Car
1999 G19E Relay problem /inconsistent power Electric Yamaha
'07 TXT Gas Suddenly Spudders along Electric EZGO
1999 Workhorse ST350 suddenly leaking oil Gas EZGO


All times are GMT -5. The time now is 05:14 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.