lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-30-2019, 02:28 PM   #1
Not Yet Wild
 
Join Date: Nov 2019
Posts: 2
Default Battery charger "Incomplete" issue

I bought a used electric Yamaha cart a couple years ago. It's driven about 1 mile/day 3/week. It occasionally has the red "Incomplete" light show up on the Yamaha charger, so I bought a 50 watt 48 volt battery maintainer. It's worked fine in the past.

A few days ago, I saw the Incomplete light so I went to plug that maintainer in using alligator clips directly to the terminals (one on the red terminal on the first battery and one on the black terminal on the last battery connected to the cart, per the maintainer's directions). It didn't work at all (no lights, no charging), so I bought a new maintainer.

Directions said to plug the maintainer into the wall first, which I did. Then I connected the red clip and when I went to connect the black clip, it sparked. I freaked out and immediately moved the clip off.

This has never happened before. I'm not sure if I have a problem with the maintainer or the golf cart batteries. The batteries were brand new 2 years ago, but I'll admit I didn't realize I had to regularly refill it with distilled water. I didn't pay enough attention to the orientation when they delivered it. Anyhow, when I popped up the covers, I could see the tops of the plates about a year ago (one year into ownership). I refilled each battery with distilled water, used the maintainer, and it was fine. I was good about refilling water every 2 months or so but then forgot this past summer. I could see the tops of the plates again so I refilled with water once I saw the Incomplete light.

Did I completely screw up the batteries? Do I need to scrub the terminals with baking soda and water? Do I need to call the local Yamaha shop and have them send someone out? Or could it be I just got 2 bad maintainers?

Thanks in advance for helping me out.
smiles33 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-30-2019, 03:22 PM   #2
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 14,215
Default Re: Battery charger "Incomplete" issue

Here's the manual for your charger, it'll tell you all about your "abnormal cycle light".
Attached Files
File Type: pdf M14486-rev-d.pdf (218.3 KB, 0 views)
cgtech is offline   Reply With Quote
Unread 12-02-2019, 10:18 PM   #3
Not Yet Wild
 
Join Date: Nov 2019
Posts: 2
Default Re: Battery charger "Incomplete" issue

Thank you for sharing the manual, but I still don't know what the answer is. I've read it through a couple times (after I figured out the pages weren't consecutive but double-sided and meant to be folded!). It talks about the red abnormal cycle but mentions a flashing red light (I have a solid red abnormal cycle light), so I don't think it's "shorted battery cells" or "output overcurrent."

I will try to call my local Yamaha dealership where I bought the golf cart tomorrow.
smiles33 is offline   Reply With Quote
Unread 12-06-2019, 08:12 PM   #4
Gone Wild
 
nickdalzell1's Avatar
 
Join Date: Oct 2011
Posts: 785
Default Re: Battery charger "Incomplete" issue

In my experience the 'incomplete' light comes on when the charger fails to reach the voltage threshold for a fully charged status cut-off within the timeout period (~16 hours). It's not a 'smart' charger aka a dv dt type, it just wants to reach a pre-defined voltage for x number of minutes to determine 'full.' If it doesn't get to that point it times out and throws that light.

Can happen if batteries get sulfation or if they're extremely low when the charge cycle starts.
nickdalzell1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
QuiQ 910-4800 battery charger doing continuous "recycling" when plugged-in to charge Columbia ParCar
For Sale: "Save A Battery" battery charger Golf Carts and Parts
EZGO portable battery charger - Not turning "ON" Electric EZGO
G22 Charger "Incomplete" Light Electric Yamaha
"incomplete" light shining on Yamaha 48V charger Electric Yamaha


All times are GMT -5. The time now is 02:13 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.