lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-02-2010, 07:56 PM   #1
Gone Wild
 
vponder's Avatar
Yamaha
 
Join Date: Dec 2009
Location: Thomasville, GA
Posts: 211
Default Normal readings

Took my G3 out tonight for about 30 mins with three people on it hit a few small hills I checked the reading on the batterys when I got back and all were reading like 6.42, 6.41 none hit the 6.38 which is the top figure on the chart thats on here, I'm pleased with the number but I would think it would have dropped some I' m hopeing the new PLUM QUICK MOTER gets the brushs seated SO I'll see some more speed, also the charger takes about 3 hours to shut off is that normal with that kind of reading? Thanks V
vponder is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
I had done everything wrong with my batteries, so why do I have these readings Electric EZGO
wacky electrical readings Electric Club Car
Spark plug readings Gas Yamaha
Voltage readings Electric EZGO
Amp readings different on two chargers Electric Club Car


All times are GMT -5. The time now is 12:53 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.