lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-23-2011, 11:31 AM   #1
Not Yet Wild
 
Join Date: May 2011
Posts: 4
Default 06 Yamaha G22 Won't Run

I have a 06 Yamaha G22e. Cart was running fine. Parked it and hooked charger to it overnight. Disconnected the charger in the morning and the cart wont run. So far I have checked the cables, tested battery pack voltage (51v) 50.9 volts at the motor. Checked 3 amp fuse, it's good. When you turn the tow switch from tow to run the solenoid clicks, you hear a low hum for about two seconds and the solenoid clicks again and hum stops. When the accelerator pedal is pressed you get the same click,hum,click but no power. I cleaned the battery connections just in case and recharged and shows fully charged but same issue. Any clues as to what to test first and how ? Any help is fully appreciated. Thanks
YamG22 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply

Tags
g22, g22e, won't run
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes



All times are GMT -5. The time now is 06:25 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.