lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-31-2008, 02:14 PM   #1
Not Yet Wild
Yamaha
 
Join Date: Jul 2008
Posts: 6
Default Yamaha G8E doing nothing

Cart is doing nothing. You turn key on, press accelerator and nothing happens. No noise, no clicking, nothing. Any suggestions would be greatly appreciated.
jpruett23 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-31-2008, 06:13 PM   #2
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,274
Default Re: Yamaha G8E doing nothing

Quote:
Originally Posted by jpruett23 View Post
Cart is doing nothing. You turn key on, press accelerator and nothing happens. No noise, no clicking, nothing. Any suggestions would be greatly appreciated.
Since you posted your serial#,You might check this out on your G8. Do you have at least 36 volts in the battery set ? The charger receptical has a "white" button (called a charge lock- won't run when charger is plugged in), many times they get "stuck". Shot it with some WD-40 and push it several times., then try the car. Should be a main fuse located next to the solenoid, check it. Let us know what you find. Dave
smallblock450sl is offline   Reply With Quote
Unread 07-31-2008, 07:36 PM   #3
Not Yet Wild
Yamaha
 
Join Date: Jul 2008
Posts: 6
Default Re: Yamaha G8E doing nothing

you must be genius!!!
Batteries were fine but the white button was stuck. Thanks for the help.
jpruett23 is offline   Reply With Quote
Unread 08-01-2008, 05:16 PM   #4
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,274
Default Re: Yamaha G8E doing nothing

Quote:
Originally Posted by jpruett23 View Post
you must be genius!!!
Batteries were fine but the white button was stuck. Thanks for the help.
I'm no genius....just alot of years working on Yamaha's. Glad to here this "trouble shooting" forum helped you. I only wish I (and other poster's help) could fix ever problem ! Now wheres the picture of your car ? Later Dave
smallblock450sl is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes



All times are GMT -5. The time now is 05:43 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.