lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-24-2016, 08:05 PM   #1
Not Yet Wild
 
Join Date: Jun 2016
Posts: 31
Default no fire

1996 club cart gas it was running when I shut off .now it has no fire. The spark plug has no spark .
Brooks15 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-24-2016, 09:45 PM   #2
Gone Wild
 
meimk's Avatar
Club Car
 
Join Date: Jun 2011
Location: Northern Indiana
Posts: 904
Default Re: no fire

96 being the changeover year, do you know if yours has a separate ignitor?
meimk is offline   Reply With Quote
Unread 08-25-2016, 06:16 AM   #3
Moderator
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,912
Default Re: no fire

Brooks? all you have to do is type in "bump" in your other thread! to bring it to the beginning!
But I'll go ahead and do it for you...

96 club car won't fire.
lockman1 is online now   Reply With Quote
Unread 08-26-2016, 07:14 PM   #4
Not Yet Wild
 
Join Date: Jun 2016
Posts: 31
Default Re: no fire

Yes it done. This is the one I was going to take the part off from. Got on it the other day. And no fire.
Brooks15 is offline   Reply With Quote
Unread 08-26-2016, 07:16 PM   #5
Moderator
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,912
Default Re: no fire

So this is the DS?
Then I'll agree with meimk about the ignitor, (at least that would be the first thing I'd look at!)
I'll post a breakdown pic in the a.m.!

lockman1 is online now   Reply With Quote
Unread 08-27-2016, 06:44 AM   #6
Moderator
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,912
Default Re: no fire

#18 is the ignitor... you'll have to remove the rev limiter (#16) to get to it!



lockman1 is online now   Reply With Quote
Unread 08-31-2016, 07:55 PM   #7
Gone Wild
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 158
Default Re: no fire

Unhook the ground wire from the rev limiter and see if it fires. Those rev limiters seem to fail pretty often.
Fairtax4me is offline   Reply With Quote
Unread 08-31-2016, 09:01 PM   #8
Not Yet Wild
 
Join Date: Jun 2016
Posts: 31
Default Re: no fire

Okay I try that this weekend.
Brooks15 is offline   Reply With Quote
Unread 09-03-2016, 09:51 PM   #9
Not Yet Wild
 
Join Date: Jun 2016
Posts: 31
Default Re: no fire

It ranning now club cart ds. Thank you guns
Brooks15 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Fire ext? Gas EZGO
Fire Electric Club Car
Ez-Go, No fire Gas EZGO
G1 gas won't fire Gas Yamaha
No Fire Big Block Talk!


All times are GMT -5. The time now is 09:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.