lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-29-2016, 09:15 PM   #1
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Aubrey, TX
Posts: 71
Default 2008 Precedent charging problems

I sold a 2008 Precedent to a couple and after a couple days they called and said it was dead. I just assumed the battery was bad so I took a brand new battery over there and installed it. 3 days later they are calling again saying it is dead.

I go get it and bring it home and did a voltage test. 12.4 while running in test mode. I have another 2008 Precedent here as well so I tested it.....15 volts. So I take the voltage regulator out of the 2nd cart and put it in the first cart. Still 12.4. So next I pull the generator out of the 2nd cart and put it in the first cart. Test it and 12.4. What the heck!

So I pull it back out and put it back in cart 2 and test it and get 14.9.


I checked the fuse on cart 1 and it is fine.

What else could causing this thing not to charge?

The only other option I added was a headlight and tail light kit.....did it to both carts using the same brand light kit.

Thanks,
Mark
markm is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-29-2016, 10:40 PM   #2
Gone Wild
 
meimk's Avatar
Club Car
 
Join Date: Jun 2011
Location: Northern Indiana
Posts: 987
Default Re: 2008 Precedent charging problems

Check your grounds. To test you can: disconnect the small yellow wire at the starter generator, run a jumper wire from that terminal on the starter generator to ground & run it for a moment while checking voltage at the battery. That should have the unit charging "full blast" (over 18 volts). If not, check to see if you have the higher voltage at the larger terminal with the white wire at the solenoid.
meimk is offline   Reply With Quote
Unread 08-30-2016, 04:27 PM   #3
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Aubrey, TX
Posts: 71
Default Re: 2008 Precedent charging problems

Ok the jumper wire produced 15+ volts. So I guess the hunt for a bad ground begins. The ones I can see off hand are all good.
markm is offline   Reply With Quote
Unread 08-30-2016, 05:16 PM   #4
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Aubrey, TX
Posts: 71
Default Re: 2008 Precedent charging problems

Found it. Thank you MEIMK.

This forum is greatness with all the experts and advice people provide.

Thanks again!
markm is offline   Reply With Quote
Unread 09-01-2016, 07:58 PM   #5
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Aubrey, TX
Posts: 71
Default Re: 2008 Precedent charging problems

Well I got a call from the buyer tonight. It died again.

So there is no rhyme or reason to the dying. This morning it wouldn't start cold. Yesterday it just died while driving and wouldn't restart. The solenoid clicks but it won't start.

Could the generator have a bad spot on the brushes/contacts?

Could it be a ground issue?


Please help so I can get these really nice people fixed.
markm is offline   Reply With Quote
Unread 09-01-2016, 08:09 PM   #6
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 1,603
Default Re: 2008 Precedent charging problems

Check the yellow DF wire, could be broken. Charge systems on these carts is very very easy
Golf cart guy is offline   Reply With Quote
Unread 09-02-2016, 04:40 PM   #7
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Aubrey, TX
Posts: 71
Default

I just picked up the cart from my customer and he said when it dies that when you push the gas pedal you hear nothing no clicks but the gas gauge goes all the way to empty every time you press the pedal. he said sometimes after pressing the pedal 10 plus times then it will start up.

He and I are both mechanically inclined and we are totally confused on what's happening.

Sent from my SAMSUNG-SM-G920A using Tapatalk
markm is offline   Reply With Quote
Unread 09-03-2016, 11:30 AM   #8
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 1,603
Default Re: 2008 Precedent charging problems

Battery is dead, and not charging-that's your issue
Golf cart guy is offline   Reply With Quote
Unread 09-03-2016, 12:14 PM   #9
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Aubrey, TX
Posts: 71
Default Re: 2008 Precedent charging problems

Bad yellow wire....fixed and charging again.
markm is offline   Reply With Quote
Unread 09-04-2016, 09:35 AM   #10
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Aubrey, TX
Posts: 71
Default Re: 2008 Precedent charging problems

Quote:
Originally Posted by Golf cart guy View Post
Battery is dead, and not charging-that's your issue
Battery is brand new and was showing 12.4 volts
markm is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Yamaha 2008 YDRE Battery Charging Problems Electric Yamaha
Have charging probably, charged a 48 volt 2008 club car precedent with for 12 hour Electric Club Car
2008 Gas Precedent Stereo Battery Charging Gas Club Car
2008 Club Car Precedent vs. 2008 ezgo pds Electric Club Car
2008 Club Car precedent vs. 2008 ezgo pds Electric EZGO


All times are GMT -5. The time now is 08:56 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.