lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-14-2017, 08:25 AM   #1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default 2011 DS runs great for about 10 mins then shuts off

Good morning. This club car is about to drive me nuts. It runs like a champ for ten minutes or so, then it will shut off. Cart has a new igniter coil and I have a spark checker on it. When it shuts down it is still showing spark. It even backfires a lil but won't run again. Now if you sit there and hit the pedal off and on it will run for maybe 3 feet and shutoff. Does this several times then every once in a while it will run again, but shuts off after a min. or so. I checked fuel pump also. Have no idea what can be causing this issue. My mom wants her cart back lol
grandpa1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-14-2017, 09:33 AM   #2
Gone Wild
 
meimk's Avatar
Club Car
 
Join Date: Jun 2011
Location: Northern Indiana
Posts: 538
Default Re: 2011 DS runs great for about 10 mins then shuts off

Check the carburetor float bowl vent, the clear plastic tube that runs from the side of the carb (just ahead of the idle mix screw) and down to the frame rail. If that tube gets plugged up it can cause issues like you describe.
meimk is offline   Reply With Quote
Unread 02-14-2017, 10:52 AM   #3
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 DS runs great for about 10 mins then shuts off

OK I am checking it right now
grandpa1 is offline   Reply With Quote
Unread 02-14-2017, 12:28 PM   #4
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 DS runs great for about 10 mins then shuts off

Vent tube is clear. It will start up for like 5 seconds and shuts off. Then I can push the pedal down hard and fast and it will run, but very rough. Put a new plug in it and 5 mins it is black already. Also I put a new igniter coil on it and it ran fine for a couple of weeks. Is it possible that air gap got off for some reason??? Not sure if it will cause this problem
grandpa1 is offline   Reply With Quote
Unread 02-14-2017, 12:37 PM   #5
Gone Wild
 
meimk's Avatar
Club Car
 
Join Date: Jun 2011
Location: Northern Indiana
Posts: 538
Default Re: 2011 DS runs great for about 10 mins then shuts off

Still sounds more like a fuel flooding problem to me. A crude test: Use a pair of pliers to pinch the rubber fuel line while you try running it in neutral (maintenance mode). Pinch the line shut & only open it to let fuel flow off & on. See if you can get it to run smoother & without the black smoke. If that works, it's time to tear the carb open & see what's up with the float & needle valve.
meimk is offline   Reply With Quote
Unread 02-14-2017, 01:24 PM   #6
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 DS runs great for about 10 mins then shuts off

Carb just got soaked and put back together. Nothing wrong. It ran for 5 seconds then shut off. Then I slammed the pedal down fast and it ran for a solid min smooth then shut off with no rough running
grandpa1 is offline   Reply With Quote
Unread 02-14-2017, 03:23 PM   #7
Not Yet Wild
Club Car
 
Join Date: Jan 2017
Location: Dakota Territory
Posts: 15
Default Re: 2011 DS runs great for about 10 mins then shuts off

Almost sounds like a faulty micro switch to me.
fishstick is offline   Reply With Quote
Unread 02-14-2017, 09:47 PM   #8
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 DS runs great for about 10 mins then shuts off

I replaced both micro switches down in the pedal box today also. I ordered another igniter coil so I can change out the other one just to rule out that issue. I honestly have no idea why it is doing this. I have checked for chaffed wires also and have found nothing.
grandpa1 is offline   Reply With Quote
Unread 02-14-2017, 10:47 PM   #9
Getting Wild
 
DannyAbear's Avatar
Club Car
 
Join Date: Mar 2012
Location: Baton Rouge, La.
Posts: 119
Default Re: 2011 DS runs great for about 10 mins then shuts off

You might want to check the tank vent; a good test would be remove the fuel cap and try it. I have had a lawn mower do the same thing.
DannyAbear is offline   Reply With Quote
Unread 02-17-2017, 08:54 AM   #10
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: 2011 DS runs great for about 10 mins then shuts off

I have done that also. I have another igniter coil coming this morning. Hope this works.
grandpa1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EC25DS runs great in reverse, not so great forward Gas EZGO
Starts great, runs great, then dies Gas EZGO
G9 runs about 30 mins and gets extremely hot Gas Yamaha
87 Columbia Gas, Runs Great, then VERY SLOW, then great Gas Columbia ParCar
Runs 10 minutes then shuts off, wait 5 then runs again... Electric EZGO


All times are GMT -5. The time now is 10:34 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.