lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-11-2017, 01:17 PM   #11
Not Yet Wild
 
Join Date: Mar 2017
Posts: 11
Default Re: 93 carryall-I drive issues

Quote:
Originally Posted by Springbok View Post
Oil level too high maybe?
That was my first thought, but oil level looks ok, tad low actually. I'll be doing a change tomorrow to be certain I add the right amount.
RodA88 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-11-2017, 03:24 PM   #12
Gone Wild
Club Car
 
Join Date: Mar 2015
Location: Montville,Ohio
Posts: 176
Default Re: 93 carryall-I drive issues

time for a compression test or a leakdown test
cruisinkruty is offline   Reply With Quote
Unread 03-11-2017, 04:10 PM   #13
Not Yet Wild
 
Join Date: Mar 2017
Posts: 11
Default Re: 93 carryall-I drive issues

Quote:
Originally Posted by cruisinkruty View Post
time for a compression test or a leakdown test
I will try that asap. Not sure what a leak down test is, time for some searching
RodA88 is offline   Reply With Quote
Unread 03-11-2017, 06:02 PM   #14
Not Yet Wild
 
Join Date: Mar 2017
Posts: 11
Default Re: 93 carryall-I drive issues

It seems to only spit out oil on bumpy rides, if I clean up the excess oil and just ride on a flat surface I don't get the oil.
RodA88 is offline   Reply With Quote
Unread 03-12-2017, 04:32 PM   #15
Gone Wild
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 155
Default Re: 93 carryall-I drive issues

The engine may be tipped too far, or the drain ports in the head might be clogged.
I don't remember is there is a breather battle in the valve cover or not, but it's easy to pop the valve cover off and make sure that's all clean.

An oil change is a good idea to start. Make sure you use 30wt SAE.

Second thought is that the air box/tube may be clogged. If it can't get air it will suck oil through the breather hose. Try running it without the air tube installed to confirm.

Where did you buy the new carb? Is it original club car or aftermarket? The Cheapo carbs don't always work so well...
Fairtax4me is offline   Reply With Quote
Unread 03-14-2017, 11:34 PM   #16
Not Yet Wild
 
Join Date: Mar 2017
Posts: 11
Default Re: 93 carryall-I drive issues

Quote:
Originally Posted by Fairtax4me View Post
The engine may be tipped too far, or the drain ports in the head might be clogged.
I don't remember is there is a breather battle in the valve cover or not, but it's easy to pop the valve cover off and make sure that's all clean.

An oil change is a good idea to start. Make sure you use 30wt SAE.

Second thought is that the air box/tube may be clogged. If it can't get air it will suck oil through the breather hose. Try running it without the air tube installed to confirm.

Where did you buy the new carb? Is it original club car or aftermarket? The Cheapo carbs don't always work so well...
I will try and remove the valve cover soon, I was not running the air box when I noticed the oil issue so I don't believe it's that. I have not had a chance to do the oil change but do you think running some sea foam might help clear the oil passages? The carb I bought was off of eBay.
RodA88 is offline   Reply With Quote
Unread 03-15-2017, 07:23 AM   #17
What the.....?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,328
Default Re: 93 carryall-I drive issues

Quote:
Originally Posted by RodA88 View Post
I will try and remove the valve cover soon, I was not running the air box when I noticed the oil issue so I don't believe it's that. I have not had a chance to do the oil change but do you think running some sea foam might help clear the oil passages? The carb I bought was off of eBay.
The intake system (air box w/filter and intake tube) should be connected to the carb for it to run right!
Kawi FE engines are really finicky about their air/fuel mixture!

lockman1 is online now   Reply With Quote
Unread 03-15-2017, 09:46 AM   #18
Not Yet Wild
 
Join Date: Mar 2017
Posts: 11
Default Re: 93 carryall-I drive issues

Quote:
Originally Posted by lockman1 View Post
The intake system (air box w/filter and intake tube) should be connected to the carb for it to run right!
Kawi FE engines are really finicky about their air/fuel mixture!

I figured as much, but I didn't have it at the time. When I first got the cart it was basically is peices, luckily I went back to scavenge for the air cleaner and was able to locate it.
RodA88 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2014 carryall 550 EFI issues Gas Club Car
VC460 in a Carryall Issues Clone Engine Swaps
93 Carryall 2. Lifted with steering issues. Gas Club Car
Carryall IV clutch issues Gas Club Car
Carryall Turf 2 power issues Electric Club Car


All times are GMT -5. The time now is 08:58 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.