lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-07-2019, 11:47 AM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2019
Location: Florida/Minnesota
Posts: 9
Default '02 stalls after warmed up

I tried the spark plug and filter, runs great for the first 8 minutes, then stalls out. It will start but won't run after it warms up. Oil level is good.
Any ideas?
Crazylegs is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-07-2019, 11:56 AM   #2
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,918
Default Re: '02 stalls after warmed up

Bring a spare spark plug. Drive it until it stops, then plug the extra spark plug in, hold it against one of the valve cover bolts and check to see if it sparks. I'll bet not.
CP241 is offline   Reply With Quote
Unread 07-07-2019, 12:17 PM   #3
Old School
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 799
Default Re: '02 stalls after warmed up

I sent you a PM CP241. See what you think
trig123 is offline   Reply With Quote
Unread 07-07-2019, 12:25 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2019
Location: Florida/Minnesota
Posts: 9
Default Re: '02 stalls after warmed up

I'll give that a try, what does that mean if I have no spark after engine is warmed up? Coil?
Crazylegs is offline   Reply With Quote
Unread 07-07-2019, 12:29 PM   #5
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,918
Default Re: '02 stalls after warmed up

Most likely either a coil, or the rev limiter. Rev limiter is easy enough to bypass and see if that's it... it's a gold box below the valve cover on the front of the motor. theres a brown wire with a ring terminal just to the left of it. Unbolt that and insulate the ring terminal so it doesnt touch metal. If all is well after that. Rev limiter is the problem. If it still has no spark, theres a single.wire with a bullet connector next to the rev limiter. Disconnect that and try. If you have spark with that unplugged, then you have a microswitch problem. If still no spark, then it is most likely the coil.
CP241 is offline   Reply With Quote
Unread 07-22-2019, 09:07 PM   #6
Not Yet Wild
Club Car
 
Join Date: Jul 2019
Location: Florida/Minnesota
Posts: 9
Default Re: '02 stalls after warmed up

I finally got some time to look at the cart tonight. Tried running it until it died, tried the plug and had spark. Removed the ring from and taped it up, still died. Changed fuel pump with new one. Still died. Spark seems to be pretty weak but I'm not sure. Now it doesn't start at all, even when cooled off. Coil?
Crazylegs is offline   Reply With Quote
Unread 07-23-2019, 11:36 AM   #7
dliw enoG
 
Fairtax4me's Avatar
Club Car
 
Join Date: Dec 2015
Location: Charlottesburg Va
Posts: 2,355
Default Re: '02 stalls after warmed up

If spark looks yellowish or is not consistent the coil has probably failed.
Spark should be bright white or blueish color and should be consistent. A bright obvious spark every revolution of the engine.
Fairtax4me is offline   Reply With Quote
Unread 07-24-2019, 07:49 PM   #8
Not Yet Wild
Club Car
 
Join Date: Jul 2019
Location: Florida/Minnesota
Posts: 9
Default Re: '02 stalls after warmed up

Latest, Still has spark and no running, will fire some but not run for more than a few seconds. I took carb apart and cleaned it, it did have some gunk in it.
Still same problem.
When this started it would run for a few blocks before it died, now it barely runs before it dies. It has gotten worse.
Oh, I pulled connection to micro switches to test that also.
I'm learning a good deal about Club Car engines, but Minnesota summer is really short. I'd like to use it before the snow flies again.
Crazylegs is offline   Reply With Quote
Unread 07-25-2019, 06:18 AM   #9
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,918
Default Re: '02 stalls after warmed up

What color is the spark?
CP241 is offline   Reply With Quote
Unread 07-25-2019, 11:23 AM   #10
Not Yet Wild
Club Car
 
Join Date: Jul 2019
Location: Florida/Minnesota
Posts: 9
Default Re: '02 stalls after warmed up

It is pretty much white, but doesn't have the wallup a vehicle does. I'm assuming that maybe normal. It seems intermittent of firing, but that could be me trying to hold the plug on the engine while pushing the accelerator.
Crazylegs is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
No power, won’t start after warmed up Gas Club Car
Club Car DS smoking when warmed up Gas Club Car
Slow to fire after warmed up Gas EZGO
G1 no start after warmed up Gas Yamaha
not turning over once warmed up Gas Harley Davidson


All times are GMT -5. The time now is 05:19 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.