lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-29-2009, 08:11 PM   #1
Not Yet Wild
 
Join Date: Nov 2009
Posts: 3
Default '92 carryall with new engine, belt slips even with new belt and motor set far forward

i have a carryall, it sat for a 6 six month while i rebuilt the engine. now everything works, except the belt slips, clutch seems to be engaging properly, but belt slips under pressure, once it picks up speed runs good, but it has a hard time getting up and going. i replaced the belt, moved the engine as far forward as i could, but still no go.
Any ideas here? thanks in advance. Alex
almiper is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-29-2009, 08:14 PM   #2
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,109
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

WELCOME TO BGW!!!!!!!!!!
That's wierd..... is there a # on the belt? Maybe you got the wrong belt?
scottyb is offline   Reply With Quote
Unread 11-30-2009, 09:21 AM   #3
Not Yet Wild
 
Join Date: Nov 2009
Posts: 3
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

the belt is the correct one, i've tried the old one and a new one i bought at the club car dealer for my serial number vehicle... after more troubleshooting seems as if the drive clutch is not opening, so now i gota figure out how to remove it and make it slide. any ideas here?

Thanks again.

Alex
almiper is offline   Reply With Quote
Unread 11-30-2009, 09:35 AM   #4
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,109
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

You will need a puller to remove the drive clutch from Club Car.
scottyb is offline   Reply With Quote
Unread 11-30-2009, 09:55 AM   #5
Not Yet Wild
 
Join Date: Nov 2009
Posts: 3
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

is that a specialty tool or can i buy it at an autozone... or similar store?

Thanks again for the quick reply.

Alex
almiper is offline   Reply With Quote
Unread 11-30-2009, 10:36 AM   #6
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,109
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

It is a specialty puller. A bolt within a bolt. It is for the clutch on the engine. The one on the rear doesn't need any special tools.
scottyb is offline   Reply With Quote
Unread 11-30-2009, 11:52 AM   #7
Bad *** Speller!
 
ckiguy's Avatar
Club Car
 
Join Date: Oct 2009
Location: Columbus, Ohio
Posts: 1,338
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

club car part number PART#1014496. ran me around 35 for a bolt with a bolt on it. but well worth the money, other then having to fiddle fart around with rods and bolts to get it out like others say can be done.
ckiguy is offline   Reply With Quote
Unread 11-30-2009, 11:57 AM   #8
Raised by coyotes
 
Flintrock's Avatar
Yamaha
 
Join Date: Nov 2008
Location: Central Texas
Posts: 5,652
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

Sounds like you are talking about the the driven clutch, on the differential?? Take a few pics, may be as simple as a cleaning and greasing....
Flintrock is offline   Reply With Quote
Unread 11-30-2009, 12:43 PM   #9
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,109
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

You Yamaha guys always want to put grease in the clutch ... ezgo and CC run em dry with plastic wear surfaces in the driven .... Often the plastic is gone and they are metal to metal by the time anyone complains about them..... ah, for the love of a little preventative maintenance
scottyb is offline   Reply With Quote
Unread 11-30-2009, 03:31 PM   #10
Bad *** Speller!
 
ckiguy's Avatar
Club Car
 
Join Date: Oct 2009
Location: Columbus, Ohio
Posts: 1,338
Default Re: '92 carryall with new engine, belt slips even with new belt and motor set far for

get him scotty!
ckiguy is offline   Reply With Quote
Reply

Tags
belt, clutch, lack of power, slip
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ GO Gas---BELT HELP Gas EZGO
belt length / engine mounting Big Block Talk!
Generator belt slips Gas Club Car
94 Carryall 36V wiring problems, no forward Electric Club Car
Engine swap belt tension Big Block Talk!


All times are GMT -5. The time now is 09:34 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.