lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-24-2008, 11:46 AM   #21
Not Yet Wild
 
Join Date: Jun 2008
Posts: 3
Default Re: 88 gas cc dies after running 20 minutes

O.K. for my 96 Club Car, I checked the spark when it was hot and sure enough it was intermittant or non-existent. I went to Club Car and got a new coil, installed it and now have no spark at all. I plan to go back in and determine that there is power to the coil, but I am bummed out as the coil is difficult to get to and it is humid today. Anyone have any other ideas?
raewillis is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-25-2008, 09:10 AM   #22
Not Yet Wild
 
Join Date: Jun 2008
Posts: 3
Default Re: 88 gas cc dies after running 20 minutes

I have replaced the coil and found that there is now no power to the coil (wire that plugs into the tab on the coil). Previously there was spark with the old coil until it got hot and then it was intermittent to nonexistent. There are no fuses blown. Can I assume the power to the coil comes from the points (I really don't know Kawasakis). What should I try now?


Quote:
Originally Posted by raewillis View Post
I have same problem with 96 gas CC. I have checked from the tank to the carb, tank cap, lines, filters, etc. I rebuilt fuel pump. Problem persists. I am going after the carb next, but this a mystery. I'd love to hear from someone who has solved this problem.
raewillis is offline   Reply With Quote
Unread 06-25-2008, 09:51 AM   #23
Gone Wild
 
clubcarjeff's Avatar
Club Car
 
Join Date: Jun 2008
Location: Austin, Tx area
Posts: 209
Default Re: 88 gas cc dies after running 20 minutes

Hey Rae.......

I believe that year/ model has an external ignitor for the coil. This will be mounted on the back of the RPM limiter (front bottom of engine). The ignitor is a silver box about 1 inch square w/ one terminal. Sounds like the problem to me. Unless the parts house where you got the coil says that your model has an ignitor in the coil, then forget everything I just said.......
clubcarjeff is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
'94 DS Gasser sporadic running... Gas Club Car
'94 DS sporadic running... Gas Club Car
Usable step/running boards Electric Club Car
My cart running Videos


All times are GMT -5. The time now is 01:18 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.