lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-17-2011, 11:11 AM   #1
Not Yet Wild
 
Join Date: Nov 2010
Posts: 11
Default Fuel pump problem

Have a 1993 Carry ALL 1 which will only run when you hold your hand over intake but not when you take hand off. Could this be a weak fuel pump. Tried switching carbs same problem. New fuel filter,lines. plug but no difference
accsupt is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-17-2011, 01:17 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Fuel pump problem

yes it could be, if your careful you can take pump apart and try cleaning it to see if it helps you just have to be careful.......................
shadowman is offline   Reply With Quote
Unread 03-17-2011, 06:15 PM   #3
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,985
Default Re: Fuel pump problem

Pull the fuel line at the carb and spin it over to check for a strong flow of
gas.
Check this post
Fuel Pump
DOOmsman is offline   Reply With Quote
Unread 03-19-2011, 09:45 AM   #4
Not Yet Wild
 
Join Date: Nov 2010
Posts: 11
Default Re: Fuel pump problem

Well changed fuel pump and still same problem.If put duct tape covering 3/4 of the intake it will run fine. I am missing something else?
accsupt is offline   Reply With Quote
Unread 03-19-2011, 10:18 AM   #5
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,985
Default Re: Fuel pump problem

Time to take the carb apart and clean every thing in it.
Use a set of torch tip cleaners to get every thing clean.
DOOmsman is offline   Reply With Quote
Unread 03-19-2011, 12:41 PM   #6
What the .... ?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 12,492
Default Re: Fuel pump problem

Quote:
Originally Posted by accsupt View Post
Well changed fuel pump and still same problem.If put duct tape covering 3/4 of the intake it will run fine. I am missing something else?
Something tells me from this quote, that you don't have your air (filter) box hooked up, and that your running an "open" carb...

IF this is true... there is obviously something you don't know,

Club Car Kawasaki OHV engines are VERY "finicky" when it comes to fuel/air mixture,
they just won't run... or run "well" without an air filter, and the the air box connected to the carb!

my .02
lockman1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1988 Parcar Fuel pump Or no Fuel pump? Gas Columbia ParCar
Fuel Pump Gas EZGO
Fuel Pump??? Gas EZGO
1987 Club Car DS Fuel Pump Problem Gas Club Car
Fuel Pump Gas EZGO


All times are GMT -5. The time now is 12:13 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.