lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-20-2011, 03:12 PM   #1
Not Yet Wild
 
Kyle's Avatar
 
Join Date: Mar 2011
Posts: 6
Default Another one not charging

I got a '93 Club Car a while back and the guy said it was not charging when I bought it, I rewired some things on the generator the way they're supposed to be and still nothing. It has a brand new S/G that is wired correctly also...What I have found is that if I by pass the VR the generator will charge about 10.5v (is that correct?), BUT it won't charge through the solenoid as it's supposed to...It will only charge if you run the generator to a ground like the battery or frame.

Does anyone know what might be wrong here?


Thanks, Kyle
Kyle is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-20-2011, 06:19 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Another one not charging

with the cart not running you should have 12 volts+ with a good battery when you start cart voltage will drop to 11.7 or so than it should climb back up to 15.3 or so volts as you rev engine..............start by making sure your battery is good......test and load test it if your battery is good the 93 has the black V.R. which quite often go bad so start there.........chances are S/G is good they rarly go bad but on the other hand the V.R,s on that cart go bad all the time............................
shadowman is offline   Reply With Quote
Unread 03-20-2011, 06:35 PM   #3
Not Yet Wild
 
Kyle's Avatar
 
Join Date: Mar 2011
Posts: 6
Default Re: Another one not charging

I had a feeling it was probably a VR issue, but also the battery is weak with about 11 volts not running. The S/G is brand new from the previous owner, so I'm 99.9% positive that's not the issue.

I will buy a new VR and see what happens, also I have a good battery I will throw in it.
Kyle is offline   Reply With Quote
Unread 03-20-2011, 06:59 PM   #4
Not Yet Wild
 
Kyle's Avatar
 
Join Date: Mar 2011
Posts: 6
Default Re: Another one not charging

Ordered up a new VR. $34.98 shipped. I expected about $100 so I'm happy
Kyle is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Run or Tow when charging normally? Golf Carts and Parts
Charging Electric Club Car
Gas 99 TXT not charging Gas EZGO
Charging Electric EZGO
Charging ???? Electric EZGO


All times are GMT -5. The time now is 05:51 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.