lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-20-2013, 07:35 AM   #1
Not Yet Wild
 
Join Date: Mar 2013
Posts: 16
Default New 6" lift - cart wont start

Installed All Sports 6" lift on cart yesterday. When finished, cart would not start - no turnover what so ever. I do not see any loose wires. Cart ran great prior to installing the lift. Today, I am going to make a new bracket for the Snubber, as the motor is at such an incline due to the new lift. Would the motor not being level have anything to do with it not starting?. Any suggestions welcomed.

Thanks
Poswego is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-20-2013, 08:09 AM   #2
Moderator
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,510
Default Re: New 6" lift - cart wont start

Older DS's had a ground strap going from the S/G to the frame, and when you lift it, the ground strap would break causing a no start situation.
Club car has since moved that ground strap, but I don't know what year they changed it.

Some basic things I would look at first...

1) a broken/disconnected ground strap
2) is the battery hooked up properly?
3) check the 10 amp fuse in the black box (electrical components box)
and then of coarse the obvious... key on? shifter in F or R?

Note: I now know you have a 2001, but always try to mention the year and model of your cart so we know what your working with!

Hope this helps!

lockman1 is offline   Reply With Quote
Unread 04-20-2013, 09:19 AM   #3
Not Yet Wild
 
Join Date: Mar 2013
Posts: 16
Default Re: New 6" lift - cart wont start

Thanks, and yes, it is a 2001 DS.
Poswego is offline   Reply With Quote
Unread 04-20-2013, 09:49 AM   #4
Moderator
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,510
Default Re: New 6" lift - cart wont start

Does your reverse buzzer sound? if so... your fuse is fine!
lockman1 is offline   Reply With Quote
Unread 04-20-2013, 10:39 AM   #5
Not Yet Wild
 
Join Date: Mar 2013
Posts: 16
Default Re: New 6" lift - cart wont start

Thanks lockman1 - after going over every inch of my cart, it ended up being a broken ground wire - heavy braided - on the top of the start/generator. It was snapped off in the protective sheath covering the ground wire, so on my first inspection, it looked like it was still good - however, when pulling on it, it came free from the sheath. Thanks again for your help, and as a newbie, next time I will remember to add the year and make of the cart. I was pretty bumbd after installing the new lift and the cart wouldn't start.
Poswego is offline   Reply With Quote
Unread 04-20-2013, 11:22 AM   #6
Moderator
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,510
Default Re: New 6" lift - cart wont start

That's not the first time I've heard that the the sheath covering the ground strap was covering the break!

I'm glad you found it somewhat quickly!

Happy carting!

lockman1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
New 6" lift, cart won't start Electric Club Car
G1 my first cart wont start Help Gas Yamaha
Cart "jerks hard" on start Gas Club Car
cart wont start Gas Club Car
Cart wont start Gas EZGO


All times are GMT -5. The time now is 12:47 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.