lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-28-2008, 05:04 PM   #1
Not Yet Wild
 
Join Date: Dec 2008
Posts: 7
Default weak spark

90 model ezgo 2cylce. what should the spark plug gap be. the spark is a dull yellow. could it be the pulser coil or ignitor? how can I check those to see if they are working properly
j1864 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-28-2008, 08:56 PM   #2
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: weak spark

Not sure about the gap, I was thinking .28, someone just posted that info in a different thread dealing with 2 strokes. As for the weak spark I doubt it's the pulsar coil sense it only tells the system when to fire. I would be guessing plug, plug wire, or coil first then igniter. The 2 strokes igniters can be replaced with the GM HEI ignition module so it's not a huge cost even if the igniter is going bad.
ruredy is offline   Reply With Quote
Unread 01-03-2009, 11:07 PM   #3
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: weak spark

Welcome to the forum j1864..................
rusty is offline   Reply With Quote
Unread 09-18-2013, 02:41 PM   #4
Not Yet Wild
 
Join Date: Aug 2013
Posts: 2
Default Re: weak spark

Hi everyone, I have been given a ezgo golf buggy for my son to do up. I know its a two stroke and I think its called a marathon engine. I have either a very weak spark, no spark and then a very bright spark. Cant figure out whats wrong with it. Can anyone give me some help. I have tested the coil, it seems within tolerance. I have removed and replaced HT lead from coil. Anyone help me please.
thanks
Dai
Wales, UK
daipower is offline   Reply With Quote
Unread 09-20-2013, 10:30 AM   #5
Gone Wild
 
Join Date: May 2013
Posts: 320
Default Re: weak spark

Don't know the yr as did not give it. if it is from yr mid 86 it is probably a 3pg robins but they made the change from the 2pg that mid yr. 2 pg will be a sideways mounted engine with belt going accross the cart were as the 3pg will have the engine facing so the belt runs from front to rear end.
Try new plug, if no go, try new plug wire as it may be weak or shorting. if that does not work, check your grounds from the battery to the engine and the frame to make sure they are solid and that the battery connectors are not corroded after the post to wire. This will be a good place to start but if still a problem trace out the wires from the pulser to make sure they are good. Poss it is the pulser itself but you never know till you trace to it.
Keep us informed.
Here is a good manual for you and the best that some one had posted before.
http://www.buggiesgonewild.com/attac...-gas-parts.pdf
redcloud is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1980 ezgo gas SPARK/NO SPARK Gas EZGO
Spark then no spark, 92 Club Car Gas Club Car
2005 EzGo Electric brakes weak Electric EZGO
Weak starter??? Gas Yamaha


All times are GMT -5. The time now is 08:29 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.