lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-19-2016, 05:51 PM   #1
Gone Wild
 
SRDCOMPOSITES's Avatar
E-Z-GO
 
Join Date: Mar 2016
Location: Tulsa OK
Posts: 168
Default 01 TXT not firing

I have spark and fixed fuel issue with new pump and fully cleaned carb fuel did come out of overflows before. valves are all at .004 cold. went to check compression and can feel air behind guard by plugs ( Head Gasket) compression reads 60 and 62PSI is this the reason for no start.

before I replace only head gasket should i go ahead and do rings aswell or just do gasket. I have new gasket already
295cc
SRDCOMPOSITES is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-19-2016, 06:11 PM   #2
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 2,149
Default Re: 01 TXT not firing

60 psi is really bad on any engine. I believe you should be around 150 or better.

The old 2 strokes will go down to 100, and still run. Yours won't.
cart around is offline   Reply With Quote
Unread 04-22-2016, 04:32 PM   #3
Gone Wild
 
SRDCOMPOSITES's Avatar
E-Z-GO
 
Join Date: Mar 2016
Location: Tulsa OK
Posts: 168
Default Re: 01 TXT not firing

Changed head gasket compression is now 100 with intake leak. And fuel blowing into airbox from carb
SRDCOMPOSITES is offline   Reply With Quote
Unread 04-22-2016, 11:04 PM   #4
Gone Wild
 
Join Date: Apr 2015
Posts: 255
Default Re: 01 TXT not firing

If fuel is blowing back into the air cleaner then check your cam timing marks and make sure you are not a few teeth off. This will also lower compression.
Recheck your valve clearance.
When you had the head off how was your valves?
my1423 is offline   Reply With Quote
Unread 04-23-2016, 08:16 AM   #5
Gone Wild
 
SRDCOMPOSITES's Avatar
E-Z-GO
 
Join Date: Mar 2016
Location: Tulsa OK
Posts: 168
Default Re: 01 TXT not firing

Quote:
Originally Posted by my1423 View Post
If fuel is blowing back into the air cleaner then check your cam timing marks and make sure you are not a few teeth off. This will also lower compression.
Recheck your valve clearance.
When you had the head off how was your valves?
Valves looked good no gap on intake. Exhaust were slightly more open but were still closing I re checked cam timing and it was off slightly 2 teeth from crank it runs now but rpms definitely go up a bit before it jumps forward or reverse I'll change the belt and see if that fixes it. Looks Stretched pretty far to me Still has blue smoke blowing through and smelling but it was shipped on its side with oil in it so I'm sure it will just burn out over time
SRDCOMPOSITES is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
txt not firing Gas EZGO
Not Firing Gas EZGO
g1 not firing Gas Yamaha
G14 Firing Problem Gas Yamaha
not firing Gas EZGO


All times are GMT -5. The time now is 04:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.