lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-11-2017, 02:10 PM   #1
Gone Wild
 
big mule's Avatar
E-Z-GO
 
Join Date: Aug 2009
Location: Santuck,Al
Posts: 1,319
Default Need help with 350 MCI not firing under compression

I'm stumped and would appreciate help with determining what is causing my MCI 350 to not fire while plugs are installed;it will produce a nice blue spark on plugs grounded to the engine if they're no plugs installed in the head but if I screw in & tighten 2 plugs in the head and use 2 additional known good & grounded plugs to plug into the coil wires it will not fire at all .I've checked the timing,changed the pulsar,ignitor & coil but still at a loss .
big mule is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-11-2017, 02:34 PM   #2
Gone Wild
 
Join Date: Apr 2015
Posts: 246
Default Re: Need help with 350 MCI not firing under compression

Check your battery voltage.
When you crank with the plugs you are loading the starter drawing more current lowering the voltage.
Good fully charged battery Should be over 11 volts while cranking.

A weak coil and or ignitor will not fire if the voltage drops to low.
A good system will not even fire below 8 volts.



Check it in multiple places. Could also have a bad connection lowing voltage to the coil ect. Check it at the battery, then at the coil, and use a ground on the battery then the block and also the coil.
my1423 is offline   Reply With Quote
Unread 01-11-2017, 02:51 PM   #3
Gone Wild
 
big mule's Avatar
E-Z-GO
 
Join Date: Aug 2009
Location: Santuck,Al
Posts: 1,319
Default Re: Need help with 350 MCI not firing under compression

Quote:
Originally Posted by my1423 View Post
Check your battery voltage.
When you crank with the plugs you are loading the starter drawing more current lowering the voltage.
Good fully charged battery Should be over 11 volts while cranking.

A weak coil and or ignitor will not fire if the voltage drops to low.
A good system will not even fire below 8 volts.



Check it in multiple places. Could also have a bad connection lowing voltage to the coil ect. Check it at the battery, then at the coil, and use a ground on the battery then the block and also the coil.

Thanks,I will double check everything .
big mule is offline   Reply With Quote
Unread 01-12-2017, 04:36 PM   #4
Gone Wild
 
big mule's Avatar
E-Z-GO
 
Join Date: Aug 2009
Location: Santuck,Al
Posts: 1,319
Default Re: Need help with 350 MCI not firing under compression

Thanks again my1423 for the quick reply & all the info you provided me .The battery voltage was low so I charged it and got the engine to finally fire up but it would not rev up much more than a fast idle & was backfiring through the carb (acting like it was out of time);I kept going over everything including timing check,adjusting valves,checking grounds etc. and when I was about ready to give up and walk away from it I decided to swap the pulsar coil wires around since the factory plug had been removed & they were butt connected and presto it runs perfect .I really believe God is trying to teach me to be more patient (which I really do need)!!
big mule is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
99 EZ GO txt. Not Firing Gas EZGO
Not Firing Gas Club Car
01 TXT not firing Gas EZGO
Not Firing Gas EZGO
g1 not firing Gas Yamaha


All times are GMT -5. The time now is 07:55 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.