lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-13-2017, 07:16 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2017
Location: s.central missouri [west plains area]
Posts: 17
Default clutch ,belt issues?

420 clone swap in my 06 txt. as in my first post. i bought longer belt from vegas carts .,and they said if i was using starter gen to make sure the belt is tight. well with the new engine i have to rev it up alot to get it to move. with this belt being tight would this cause this to happen? with the old engine the belt was loose enough to remove it by hand. ...and i had great top speed.
buster two is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-13-2017, 07:46 AM   #2
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 1,890
Default Re: clutch ,belt issues?

Do you think they meant that the belt to the starter/generator should be tight, and not the drive belt?
cart around is online now   Reply With Quote
Unread 12-13-2017, 05:00 PM   #3
Gone Wild
 
Rooster59's Avatar
E-Z-GO
 
Join Date: Jul 2017
Location: East Central Missouri
Posts: 1,239
Default Re: clutch ,belt issues?

It might be a little too tight now?
Rooster59 is offline   Reply With Quote
Unread 12-13-2017, 09:33 PM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2017
Location: s.central missouri [west plains area]
Posts: 17
Default Re: clutch ,belt issues?

to day pulled engine,engine plate,and cradle
added some metal to cradle, drilled some more holes and elongated them with plasma cutter. reinstalled engine and adjusted just so the belt could be removed by hand.....works just like it should. in neutral revved up,both clutches work like they should ,and driving it top end is the same. that said ,fast idle creeps along at a good pace. if any one is going to use original clutches position engine so that drive belt can be removed by hand. use this as a starting point!!!! save yourself some grief.

Last edited by buster two; 12-13-2017 at 09:39 PM.. Reason: add some more text
buster two is offline   Reply With Quote
Unread 12-13-2017, 09:42 PM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2017
Location: s.central missouri [west plains area]
Posts: 17
Default Re: clutch ,belt issues?

Quote:
Originally Posted by cart around View Post
Do you think they meant that the belt to the starter/generator should be tight, and not the drive belt?
no, i think they were talking about the drive belt that they sold me.
buster two is offline   Reply With Quote
Unread 12-13-2017, 09:46 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2017
Location: s.central missouri [west plains area]
Posts: 17
Default Re: clutch ,belt issues?

Quote:
Originally Posted by Rooster59 View Post
It might be a little too tight now?
moved engine about 3/4 to 7/8" towards rear end. that did the trick.
buster two is offline   Reply With Quote
Unread 12-14-2017, 05:01 AM   #7
Gone Wild
 
Rooster59's Avatar
E-Z-GO
 
Join Date: Jul 2017
Location: East Central Missouri
Posts: 1,239
Default Re: clutch ,belt issues?

It was a stab in the dark but glad it worked. When I installed a shorter belt (40-3/8") on my EH29 it acted a little like that until It had an hour or two on the belt.

Sent from my Moto G (4) using Tapatalk
Rooster59 is offline   Reply With Quote
Unread 12-14-2017, 07:34 AM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2017
Location: s.central missouri [west plains area]
Posts: 17
Default Re: clutch ,belt issues?

getting to know my new altered ride real well.ha ha now to order a 5pin relay to shut engine down when you let off of petal., add some more lights, a wench project complete. oh and adjustable carburetor with pulse spacer for the fuel pump. i use this ride at least twice a day around the farm ,also to visit neighbors ,and to deer hunt.,i have a diesel Kabota but in the winter don't like the wait to warm up.
buster two is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Belt and Clutch Issues Gas Yamaha
New belt issues Gas EZGO
G16 belt and clutch issues Gas Yamaha
Belt/Clutch Issues Big Block Talk!


All times are GMT -5. The time now is 07:45 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.