lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-26-2018, 06:08 AM   #1
Not Yet Wild
 
Join Date: Aug 2016
Posts: 5
Default Fuel pump?

I tried starting my 1997 ezgo(txt maybe)this spring, turns over no fire. Had spark, little fuel in filter but seemed like pump wasn’t working. I primed the filter and line to pump, it started right up, ran fine for the day. 2days later, same issue, no fire. Primed filter and line and ran fine. Any suggestions?

Thank you
jjjjjreynolds is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-26-2018, 08:34 AM   #2
BGW Sponsor
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,976
Default Re: Fuel pump?

Replace the vacuum line from the pump to the engine block. If the problem persists replace the pump.
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1 empty fuel filter=bad fuel pump or tank vaccuum? Gas Yamaha
Fuel line from valve cover to fuel pump Gas Yamaha
1988 Parcar Fuel pump Or no Fuel pump? Gas Columbia ParCar
g1 new fuel pump still wont pump HELP Gas Yamaha
fuel pump not putting out fuel Gas EZGO


All times are GMT -5. The time now is 05:03 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.