lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-13-2018, 05:21 PM   #1
Not Yet Wild
 
Join Date: Oct 2017
Posts: 19
Default 1982 ezgo runs good in reverse and sputters in forward

I've been fighting this cart for a year now and am ready to pull my hair out...I bought this running this way and guy said it sat 2 years and just needs a tune-up.. so I put new spark plug fuel and air filter along clean tank out with new premixed fuel because don't have self mixer.. still same runs awsome in reverse and sputters and now power in forward so bought new carb and fuel pump and put on still no change... So after reading on here I pulled motor checked exhaust and was good.. so replaced crank seals and bought new jug and top end kit and put on and yes I put piston with open side facing carb ... Did everything to specs and put motor back in and still same thing... can anyone please help thanks

Sent from my Pixel XL using Tapatalk
j-bro738 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-14-2018, 02:24 AM   #2
British and proud
 
Cartmaster's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: United Kingdom
Posts: 644
Default Re: 1982 ezgo runs good in reverse and sputters in forward

It is probably down to ignition timing. Sorry i dont know these older cart engine very well but someone will be here shortly to sort you out.
Cartmaster is offline   Reply With Quote
Unread 05-14-2018, 01:39 PM   #3
Not Yet Wild
 
Join Date: Oct 2017
Posts: 19
Default Re: 1982 ezgo runs good in reverse and sputters in forward

Ok thanks.. yeah that's what I'm thinking but don't know the ignition very well on these things..

Sent from my Pixel XL using Tapatalk
j-bro738 is offline   Reply With Quote
Unread 05-14-2018, 02:01 PM   #4
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,659
Default Re: 1982 ezgo runs good in reverse and sputters in forward

Generally when the two strokes run better in reverse either compression is getting low or crank seals are bad may want to do a compression check and if that checks out crank seals probably need changed
Spicyunicorn is offline   Reply With Quote
Unread 05-14-2018, 02:40 PM   #5
Not Yet Wild
 
Join Date: Oct 2017
Posts: 19
Default Re: 1982 ezgo runs good in reverse and sputters in forward

Ok just replaced both seals and put new top end kit in. Jug piston rings ect.. now I did do a compression check and both ways is 122

Sent from my Pixel XL using Tapatalk
j-bro738 is offline   Reply With Quote
Unread 05-14-2018, 03:13 PM   #6
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,659
Default Re: 1982 ezgo runs good in reverse and sputters in forward

I'm sorry I missed the first post that stated you do the top end and seals so we can rule that out have you looked into the hei conversion? Heres a good write up on it Installing HEI Ignition on 3PG Carts
Spicyunicorn is offline   Reply With Quote
Unread 05-14-2018, 03:27 PM   #7
Not Yet Wild
 
Join Date: Oct 2017
Posts: 19
Default Re: 1982 ezgo runs good in reverse and sputters in forward

Its ok and No I've heard about it though.. thanks I'll have to check that out

Sent from my Pixel XL using Tapatalk
j-bro738 is offline   Reply With Quote
Unread 05-14-2018, 08:56 PM   #8
Not Yet Wild
 
Join Date: Oct 2017
Posts: 19
Default Re: 1982 ezgo runs good in reverse and sputters in forward

Does anyone now how to test pulsar coil timing ect?? Thanks



Sent from my Pixel XL using Tapatalk
j-bro738 is offline   Reply With Quote
Unread 05-17-2018, 12:08 PM   #9
Not Yet Wild
 
Join Date: Oct 2017
Posts: 19
Default Re: 1982 ezgo runs good in reverse and sputters in forward

No one know??

Sent from my Pixel XL using Tapatalk
j-bro738 is offline   Reply With Quote
Unread 05-17-2018, 12:18 PM   #10
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 2,281
Default Re: 1982 ezgo runs good in reverse and sputters in forward

Page L-14
Attached Files
File Type: pdf 85-EZGO(2) (1).pdf (6.71 MB, 0 views)
cart around is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO runs in reverse, not forward Gas EZGO
89 CC Gas runs good in reverse, poor in forward Gas Club Car
97 ezgo runs reverse no forward Electric EZGO
82 D3 Hd goes in reverse but sputters forward Gas Harley Davidson
80 EZGO runs good reverse not forward Gas EZGO


All times are GMT -5. The time now is 12:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.