lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-04-2018, 04:40 PM   #1
Not Yet Wild
 
Join Date: Jun 2018
Posts: 10
Default 98 gas ezgo voltage issue

Background: cart ran fine for an entire round then no power to turn over starter. Replace battery and try to start. No problem. Haul it to the course and went to unload and no go.
Trouble shooting preformed. 12 volts on the batt, micro switch checks out ok with continuity on my meter, same with the key switch. 12 volts on one side of the key switch with key off. Turn key on and press the pedal and voltage drops right off. Take the wire running from the key switch off the solenoid and 12 volts on the wire. Check the forward/ reverse relay and switch seems ok. Circuit opens and volts are at 12. Replace the solenoid and still nothing. Test the solenoid with meter and all seems ok according the walk through I saw online. Starter side of the solenoid has very little voltage. I'm thinking its a ground. Put red probe from my meter on b+ and take negative probe and touch all the grounds I am aware of. All show 12 v on my meter. Something is killing the voltage getting to the starter side of the solenoid. What can I be missing. One other thing just as a test. I jumped a wire for a sec from the batt to the started and turns right away. Also put jumper on micro switch and key switch to take them out of the equation and same result. Even placed a jumper from the return to the solenoid side straight to the starter and it doesn't fire. What am I missing?
Canucgolfer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-05-2018, 08:22 AM   #2
Not Yet Wild
 
Join Date: May 2018
Posts: 8
Default Re: 98 gas ezgo voltage issue

I have the same problem with my 1998 ergo I posted a few day ago got a few replies but I have no power to the foot pedal switch and no spark let me know if you find out what wrong dcdean
Dcdean is offline   Reply With Quote
Unread 06-10-2018, 03:48 PM   #3
Not Yet Wild
 
Join Date: Jun 2018
Posts: 10
Default Re: 98 gas ezgo voltage issue

Anyone know if a bad voltage regulator would kill proper voltage back to the starter side of the solenoid?
Canucgolfer is offline   Reply With Quote
Unread 06-14-2018, 07:46 PM   #4
Not Yet Wild
 
Join Date: Jun 2018
Posts: 10
Default Re: 98 gas ezgo voltage issue

Figured out the issue due to pure stubbornness. With meter on battery side of solenoid. 12 volts as normal. Turn on key and press pedal. Meter still on battery side of solenoid. No voltage. I’m thinking bad ground somewhere as everything else checks out. Get battery charger and put neg to batt and positive to batt side of solenoid. Put it on boost and push the pedal. Darn thing fires. Run jumper from batt + to batt side of solenoid and away she goes. End of the day the wire from batt+ to solenoid had too much corrosion that it would crap out when under load. Change cable and ready to rock
Canucgolfer is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ GO Voltage drop issue Electric EZGO
Troubleshooting Voltage Issue Gas EZGO
1995 Ezgo 36v Medalist Voltage issue Electric EZGO
Voltage reducer issue Electric EZGO
1995 EZGO Starter Generator Voltage issue Gas EZGO


All times are GMT -5. The time now is 09:21 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.