lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-17-2018, 02:38 PM   #1
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default 1997 295 Robins EZGO stating issue

Ive had my cart for about a year and a half (1997 ezgo). It had engine issues and was rebuilt this spring (valves, rings). No matter what though, it is a pain to start. I have made sure the valve lash is at .004, have good compression on both cylinders (150 each), and have replaced the carburetor (cleaned really well), and the fuel pump. It has a hard time turning over after it sits for a few minutes, and we have to feather the pedal. This has been like that ever since we got the cart. When we do get going, it acts like it is starved for fuel, then sputters a bit and gets going. When it does get going it has good speed and has no issues with hills, just a little loud.

When it the engine was rebuilt, i was told eventually I would need a new muffler, this wouldn't cause these issues, would it? Any thoughts on this would be greatly appreciated.
nigilcv is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-17-2018, 08:20 PM   #2
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,088
Default Re: 1997 295 Robins EZGO stating issue

Is your choke working the butterfly in the carb?

Are you using the choke?

I would also check the float level is not set to low,

Take the air cleaner out, put your fingers over the carb. opening and crank the engine. You should have a good suction pulling on your fingers.

After cranking on the engine and it not starting, pull one of the spark plugs, is it wet (fuel) or dry?

150 compression is not very good for a newly rebuilt engine! should be around 175 psi.
Gearhead1956 is offline   Reply With Quote
Unread 09-17-2018, 08:24 PM   #3
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: 1997 295 Robins EZGO stating issue

OK I'll check the plugs and recheck valve Compresion this weekend. Plugs seem dry when I checked them last. Could a bad or improper spark gap make it hard to start up?


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 09-17-2018, 08:28 PM   #4
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,088
Default Re: 1997 295 Robins EZGO stating issue

Yes, and after cranking the engine for a while without it starting, one would expect the plugs to be wet with gas.
Gearhead1956 is offline   Reply With Quote
Unread 09-17-2018, 08:32 PM   #5
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: 1997 295 Robins EZGO stating issue

Thanks, I'll report back this weekend when I get in front of the cart.

Figured I've lurked long enough trying to decide the issue from other posts...


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 09-22-2018, 08:43 PM   #6
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: 1997 295 Robins EZGO stating issue

So...compression is 165 on both sides. sparknplugs are wet wirhbgas and good spark...checked fuel from pump and rhats good. valves were at .005 and redone at .004 getting it ip the nunber above. have to feather the pedal very slowly, cart will start then bog down, but thenbis good. after sitting for a few minutes sy.ptoms return.

time to check solenoid, ignitor etc?


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 09-22-2018, 09:06 PM   #7
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 596
Default Re: 1997 295 Robins EZGO stating issue

The linkage on these carts have to be correct. Pain sometimes getting the right way.
Have you got another known good coil you could stick on it ? One I worked on a few weeks was giving me fits bogging down and you had to feather the pedal to get it going. I set the valves many times thinking I might have missed something.
It had an aftermarket coil on it. It showed good with my meter but when I put an OEM coil on it the thing ran perfect. Stuck the other one on and same thing. Back with OEM and it runs like a few cart again.
trig123 is offline   Reply With Quote
Unread 09-22-2018, 09:07 PM   #8
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: 1997 295 Robins EZGO stating issue

Ill have to another one and check...this thing is starting to p@&$ me off


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 09-23-2018, 06:27 AM   #9
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,088
Default Re: 1997 295 Robins EZGO stating issue

Ok, compression is better, your getting fuel.

Maybe the carb is dumping to much fuel. check your oil, does it have a gas smell??
Gearhead1956 is offline   Reply With Quote
Unread 09-23-2018, 12:20 PM   #10
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: 1997 295 Robins EZGO stating issue

Cant smell gas... ill pull the carb and clean it again.


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1997 TXT carb issue Gas EZGO
1995 EZGO Gas Robins Pulsar Issue Gas EZGO
87 marathon with Robins 244 issue. Gas EZGO
1997 DCS 9 wire harness issue Electric EZGO
Robins 295cc Oil Leak and Engine Issue Gas EZGO


All times are GMT -5. The time now is 07:51 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.