lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-13-2019, 07:16 PM   #21
Not Yet Wild
E-Z-GO
 
Join Date: May 2013
Location: East Tennessee
Posts: 17
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

Not to worry, I’m sure we’ll get it figured out. There’s plenty of knowledgeable folks here!
gened4288 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-17-2019, 08:45 PM   #22
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

After defrosting the garage, after the polar vortex, this is what Iíve found:

after swapping the brakes because they were frozen and shot, pulling the neutral lock out as far as it would go, and trying to adjust the cables, the cart still will not go forward/reverse. I jacked it up and took off the hubs and the axle on both sides spins but no wheel movement.

When I look online, I canít tell what I need, anyone have a 1997 + parts manual? The ones linked here seem to be for 2002 and up.

Appreciate all the feedback from the site.


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 02-18-2019, 04:56 PM   #23
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,421
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

Quote:
Originally Posted by nigilcv View Post
I jacked it up and took off the hubs and the axle on both sides spins but no wheel movement.

did you check the axle splines in the hubs?
StoveBolt is offline   Reply With Quote
Unread 02-18-2019, 05:03 PM   #24
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,421
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

...
StoveBolt is offline   Reply With Quote
Unread 02-18-2019, 09:33 PM   #25
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

The axles splines were definitely the worse between the two...


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 02-19-2019, 06:46 AM   #26
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,421
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

Quote:
Originally Posted by nigilcv View Post
The axles splines were definitely the worse between the two...


Sent from my iPhone using Tapatalk
Hub not stripped huh?
StoveBolt is offline   Reply With Quote
Unread 02-20-2019, 07:29 PM   #27
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

I plan on replacing them regardless as theyíre the the originals.


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 02-21-2019, 05:17 PM   #28
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,421
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

are the axles spinning but the hubs not?
StoveBolt is offline   Reply With Quote
Unread 02-21-2019, 07:57 PM   #29
Not Yet Wild
 
Join Date: Oct 2017
Posts: 34
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

That is correct


Sent from my iPhone using Tapatalk
nigilcv is offline   Reply With Quote
Unread 02-22-2019, 07:03 AM   #30
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,421
Default Re: Added shorter belt to 97 TXT and now no forward or reverse

Quote:
Originally Posted by nigilcv View Post
That is correct


Sent from my iPhone using Tapatalk
Then I guess a stripped hub is your problem?, make sure you look up the torque specs when you install the new ones, they have to be tight or you will have the same trouble
StoveBolt is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
shorter belt Gas EZGO
Shorter belt Gas EZGO
replacing alternator/starter belt with shorter belt Gas Club Car
Shorter belt ? Gas Club Car
Shorter belt Gas EZGO


All times are GMT -5. The time now is 04:05 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.