lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-10-2019, 05:25 PM   #131
Perpetually confused.
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 863
Default Re: ezgo 350 oil pressure prime

Hmm... maybe I'm about right on with the pressure then. I'll watch it closer tomorrow and take it for a long drive and report the findings. Hope for the best!
CP241 is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-10-2019, 08:01 PM   #132
Gone Wild
E-Z-GO
 
Join Date: Sep 2009
Location: South :) where its hot
Posts: 304
Default Re: ezgo 350 oil pressure prime

I am not sure how a MCI engine gets oil to cam and rocker arms. Not set up like the Pre-MCI engines.

On the fan side of engine where camshaft goes in head there is an oil hole. I don't see one of the seal side so how does it get oil on the top side other than the one hole I showed in picture.

The engine I have was run without oil and the head is toast. Looks like cam was robbed of oil on seal side and it is also ruined. Other side looks great but that's where the oil hole is.

I showed damage in pictures. The block also has a nice looking oil in the side where rod stuck through.
Attached Images
File Type: jpg 100_4217.jpg (129.7 KB, 0 views)
File Type: jpg 100_4220.jpg (88.4 KB, 0 views)
File Type: jpg 100_4222.jpg (172.6 KB, 0 views)
trig123 is online now   Reply With Quote
Unread 01-10-2019, 08:14 PM   #133
Perpetually confused.
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 863
Default Re: ezgo 350 oil pressure prime

Quote:
Originally Posted by trig123 View Post
I am not sure how a MCI engine gets oil to cam and rocker arms. Not set up like the Pre-MCI engines.

On the fan side of engine where camshaft goes in head there is an oil hole. I don't see one of the seal side so how does it get oil on the top side other than the one hole I showed in picture.

The engine I have was run without oil and the head is toast. Looks like cam was robbed of oil on seal side and it is also ruined. Other side looks great but that's where the oil hole is.

I showed damage in pictures. The block also has a nice looking oil in the side where rod stuck through.
Ouch!

Now that's just ugly. Is there anything salvageable from that motor? Looks like it is time to talk your buddy into selling that spare!
CP241 is online now   Reply With Quote
Unread 01-10-2019, 08:31 PM   #134
Gone Wild
E-Z-GO
 
Join Date: Sep 2009
Location: South :) where its hot
Posts: 304
Default Re: ezgo 350 oil pressure prime

Is there anything salvageable from that motor? Yes
The valve cover

I can still use things like the timing parts and always need bolts and other small things that didn't require lubrication

My friend who has the MCI new in box will never use it. I will give him a call in the next few days.
trig123 is online now   Reply With Quote
Unread 01-10-2019, 09:00 PM   #135
Perpetually confused.
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 863
Default Re: ezgo 350 oil pressure prime

Lol

Can never have enough spare bolts! Guess the valves and cam and stuff are probably okay. My cam locked enough to break the belt but looked nothing like that! If it looked anywhere near that bad I would have just scrapped the motor and put something else in.

I have a spare side cover with a hole behind the oil pump if you want it lol
CP241 is online now   Reply With Quote
Unread 01-11-2019, 08:58 PM   #136
Gone Wild
E-Z-GO
 
Join Date: Sep 2009
Location: South :) where its hot
Posts: 304
Default Re: ezgo 350 oil pressure prime

My camshaft is ruined where it rides in the seal end. Head is no good. I am installing a Pre-MCI engine is this workhorse I have. I got one that is complete, even with muffler. I will let you know how it goes. Tom.
trig123 is online now   Reply With Quote
Unread 01-12-2019, 01:26 AM   #137
Perpetually confused.
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 863
Default Re: ezgo 350 oil pressure prime

On a positive note, I drove the hell out of it today. All in all I probably put a good 10 miles or so on it, watching the pressure gauge the entire time. It never lost pressure once like it did before. Cruising slower speed, 1/3 to 1/2 throttle it held a pretty steady ~20psi. So I disconnected the gauge and hooked the factory light back up and I'll keep driving it. The way I look at it, if the light doesnt come on, it's good! If I keep watching the gauge I will obsess and it will drive me nuts. But it's running awesome now, like a freshly rebuilt motor should! I'll keep an eye on it and update if anything should change. But I'll keep my fingers crossed this one is fixed.
CP241 is online now   Reply With Quote
Unread 01-12-2019, 05:21 PM   #138
Perpetually confused.
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 863
Default Re: ezgo 350 oil pressure prime

I'm gonna knock on wood and call this one good. I dont know if it was switching thr rod caps, I also swapped the check ball and spring from my old side case (forgot to mention that part, sorry just now remembered I did that).

My dogs keep dragging dead animal parts into our yard from the cotton field next door, so my wife and I took a very long ride today through the field, trying to find the source (we did...) and then took the long way home. Ran great the entire time and light never came on while driving. When stopping or creeping veeerrryyyy slowly (real low engine speed) the light would flicker a little, but if you step on the gas it would go right out. I'd assume the oil pump just isnt spinning fast enough going that slow to build pressure. But did a lot.of mid-speed driving and a couple full speed runs that were about a mile or so each. No problems at all (aside from the oil leak... I'll fix that Monday when I can pick up a new cam cap gasket from the dealer).

Knock on wood, but we rode it pretty hard today through that field and all was great. Except the tear in the seat back cover that I JUST recovered last.weekend from a tree branch I underestimated. doh!
CP241 is online now   Reply With Quote
Unread 01-12-2019, 06:34 PM   #139
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,081
Default Re: ezgo 350 oil pressure prime

Well sounds like you can get some good sleep tonight and not be thinking about what the h-ll is going on

Not quite sure what we learned here, but maybe just don't give up!

just noticed this thread has had 2279 views so lots of interest! So what's next on the list to tear up? LOL
Gearhead1956 is offline   Reply With Quote
Unread 01-12-2019, 06:48 PM   #140
Gone Wild
 
dirtyyoda77's Avatar
E-Z-GO
 
Join Date: Feb 2010
Location: Ocala, FL
Posts: 301
Default Re: ezgo 350 oil pressure prime

great job
dirtyyoda77 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 EZGO TXT losing prime Gas EZGO
robin 295 oil pump prime Gas EZGO
oil pump prime Gas EZGO
EZGO gas cart losing prime Gas EZGO
Loss of fuel prime Gas EZGO


All times are GMT -5. The time now is 05:56 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.