lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-12-2019, 06:05 PM   #141
Old School
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 801
Default Re: ezgo 350 oil pressure prime

So is the preflight checklist complete for takeoff even with the flicker
trig123 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-12-2019, 07:18 PM   #142
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,922
Default Re: ezgo 350 oil pressure prime

I'm gonna say yes lol. With as much abuse as I've put it through the last couple days, if it hasn't broken yet then it's not going to :)

The more I think about it, the more I really think the oil pressure bouncing around the way it was, was caused by that check ball and spring hanging open or getting stuck, and allowing the oil pressure to bypass. That's really the only thing that makes sense with the way it fluctuated as much as it did. Rods, caps, worn bearings or whatever will wear and lose oil pressure but wouldnt make it bounce around like it was. And my initial issue of it losing prime, was the pinhole behind the oil pump gear.

I'm gonna keep beating on it, but today we rode it for a straight hour, basically non-stop. Maybe stopped for 30 seconds a few times, but it was a solid hour of driving through cotton field, bumps and torture.

The flicker is literally like a half second or so when you stop or just start. If you weren't looking for it or compulsively staring at the light bulb you probably woildnt even notice it :)
CP241 is offline   Reply With Quote
Unread 01-20-2019, 10:47 PM   #143
Old School
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 801
Default Re: ezgo 350 oil pressure prime

I hope yours stays together. Not sure what you did to it but if you say it ok then I believe you.



I am still not sure how the other end of this MCI camshaft gets oil. I am currently working on a MCI 11 hp that has been sitting four years outside . Plenty of old gas in it. Also had about 1/2 gallon of old gas in crankcase. My shop has that nice old gas smell now :)

I drained everything out of crank , changed to fresh oil. Cleaned the carb and tank. Adjusted valves. Compression is 170 on both cylinders.

Got it going today and decided to take a look under the valve cover. I included a short YouTube video of what it should look like when oiling correct.

Runs great. Don't even need a choke on this engine the way I see it.

Take a look Gearhead1956 and you will see where the oil is going in this head.

By the way I ran the cart for and hour and the oil light goes out the second you touch the gas pedal. No delays at all.

https://www.youtube.com/watch?v=cWpP...ature=youtu.be
trig123 is offline   Reply With Quote
Unread 01-20-2019, 11:04 PM   #144
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,922
Default Re: ezgo 350 oil pressure prime

It's been good, no problems. It does make quite a mess spinning it over with just the oil fill lid removed. The light was never a full light, just like a half lit flicker for a second and went out pretty much instantly.

No, dont think I've ever used the choke on it. I've never needed it.

And no idea how that side of the cam gets oil. I guess it must not need much? It certainly cant be getting much by way of that little slot in the top of the lobe...
CP241 is offline   Reply With Quote
Unread 01-20-2019, 11:09 PM   #145
Old School
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 801
Default Re: ezgo 350 oil pressure prime

Mine did not flicker today at all. The other one I worked on the light goes out the split second you look at the gas pedal , even when hot. The video I included what when the engine was hot.

The other engine I have that was trashed had no oil hole in head but it could have been covered up with metal being it did a job on both cam and head. I looked good yesterday when I took it completely apart to see what I could salvage and as of yet I see no oil passage. Good luck with yours. I am not off to another workhorse. Tom
trig123 is offline   Reply With Quote
Unread 01-21-2019, 08:52 AM   #146
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,088
Default Re: ezgo 350 oil pressure prime

Trig123, one thing I noticed in your vid, 2 rocker getting flooded with oil, the other 2 not so much??

That's not a splash system. There has to be a passage somewhere. Wondering if there is a nozzle like used in large diesel engines to cool and lube the under side of the pistons?
Gearhead1956 is offline   Reply With Quote
Unread 01-21-2019, 09:21 AM   #147
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,922
Default Re: ezgo 350 oil pressure prime

The only chance of that I could see, is the excess oil from the hole on the fan side of the camshaft, shooting out through that notch in the top of the galley, across the head into the notch in the top of the galley on the opposite side?

Which doesn't make much sense on from a design standpoint... that's quite a long shot. I have to believe there is some other method of oiling the belt side of the camshaft other than just "splash" and hoping it makes it where it needs to go...
CP241 is offline   Reply With Quote
Unread 01-21-2019, 10:01 AM   #148
Old School
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 801
Default Re: ezgo 350 oil pressure prime

I will research it more. I just happen to have this cart in my shop now with the MCI engine and the valves needed adjusting so I thought I would take a closer look. Without making a mess

These MCI engines shoot the oil horizontal . Pre-MCI engines shoot oil up and down and in your face if so happen to stick you head close

I got another MCI engine that was trashed on the workbench. I took everything out of it this weekend to save what I could. It has a hole in side of block . Both pistons look fine and I think crank might clean up but not 100 % sure yet. One rod looks like new, the other not so new :(


The person that I got the trashed engine from said it was ran without oil.

I guess I just like to find out things and this camshaft oiling problem is bugging me
trig123 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 EZGO TXT losing prime Gas EZGO
robin 295 oil pump prime Gas EZGO
oil pump prime Gas EZGO
EZGO gas cart losing prime Gas EZGO
Loss of fuel prime Gas EZGO


All times are GMT -5. The time now is 11:35 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.