lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-01-2018, 09:53 PM   #11
Perpetually confused.
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 1,211
Default Re: ezgo 350 oil pressure prime

I filled it through the sensor hole again, runs great and light is off. Start and stop and all is well. After sitting for 10 min, loses prime and no oil pressure again.

Ordered a new oil filter, oil pump cover and o-ring. I'll replace those next weekend or so and update good or bad. If bad then I'll pull the motor again and double check the o-ring inside the cover. But with any luck this will take care of it!
CP241 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-02-2018, 08:31 AM   #12
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,087
Default Re: ezgo 350 oil pressure prime

[QUOTE=CP241;1564294]I filled it through the sensor hole again, runs great and light is off. Start and stop and all is well. After sitting for 10 min, loses prime and no oil pressure again.

Ordered a new oil filter, oil pump cover and o-ring. I'll replace those next weekend or so and update good or bad. If bad then I'll pull the motor again and double check the o-ring inside the cover. But with any luck this will take care of it![/QUOTE

I got a Hondo $ that says that will solve the issue!

That is exactly how mine would do.
Gearhead1956 is offline   Reply With Quote
Unread 12-02-2018, 12:07 PM   #13
Perpetually confused.
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 1,211
Default Re: ezgo 350 oil pressure prime

I sure hope so! I'll update as soon as I get them on either way.
CP241 is offline   Reply With Quote
Unread 12-02-2018, 05:32 PM   #14
Gone Wild
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 395
Default Re: ezgo 350 oil pressure prime

If you still had the original O-ring I would put it back on. I am betting that will fix your problem. Too much space between the gears and plate would probably cause it to lose prime.

I had an engine sitting on my workbench today. I looked close at the cover you are talking about and you can actually see where the gear rubbed it. Those extra fat O-rings need to be tossed in file 13
trig123 is online now   Reply With Quote
Unread 12-02-2018, 05:46 PM   #15
Perpetually confused.
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 1,211
Default Re: ezgo 350 oil pressure prime

I do still have the original o ring. But not tearing the covers and stuff off again until I have a new cover to put on it. I'll do it all at once. I've got the carryall to haul stuff around so not in a huge rush. :) I'll replace all and be sure to follow up.
CP241 is offline   Reply With Quote
Unread 12-09-2018, 09:17 AM   #16
Perpetually confused.
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 1,211
Default Re: ezgo 350 oil pressure prime

Quote:
Originally Posted by Gearhead1956 View Post

I got a Hondo $ that says that will solve the issue!

That is exactly how mine would do.
I'll take that $100 now lol. Replaced oil filter and o ring, oil pump cover and o ring. And applied some grease on both o rings to be sure they seal. There was a little dirt under the oil pump cover o ring so I was sure that was it. Nope. If anything it lost prime faster than before lol. So pulled the engine and the case cover off per trig's suggestion. The original o ring inside the case was super hard and dry and sort of smashed and deformed. So I really think that was it. Replaced it, and put the side cover back on. I'll try and get the motor put back in today and I'll follow up with results. Fingers crossed!
CP241 is offline   Reply With Quote
Unread 12-09-2018, 09:56 AM   #17
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,087
Default Re: ezgo 350 oil pressure prime

Wooops,
Gearhead1956 is offline   Reply With Quote
Unread 12-09-2018, 10:05 AM   #18
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,087
Default Re: ezgo 350 oil pressure prime

ok, I am blind and cant remember S--t

There is an o-ring in the block, I believe my rebuild kit came with one, so it was replaced.
Gearhead1956 is offline   Reply With Quote
Unread 12-09-2018, 11:32 AM   #19
Gone Wild
 
Gearhead1956's Avatar
Mixed Breed
 
Join Date: Dec 2010
Location: Woodstock,GA
Posts: 1,087
Default Re: ezgo 350 oil pressure prime

Just a thought, You could use a impact and bench test before you reinstall.

I don't know, but seem a little strange? You did have a o-ring in place and a new gasket.
but this pump design makes the pump pull a long way to get oil. not what I am used to dealing with. Most pumps are made to push and are mounted closer to the sump.
Gearhead1956 is offline   Reply With Quote
Unread 12-09-2018, 02:07 PM   #20
Perpetually confused.
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 1,211
Default Re: ezgo 350 oil pressure prime

Yes very strange indeed. But still a no-go. New o ring in the block, new filter and o ring, and new cover and o ring. Still no dice. If I prime it through the sensor hole, test light turns off immediately and I drove it about 2 or 3 miles around my yard, no issues. Smooth, quiet, strong. Runs like a new engine should. But... if I Stop for 5 minutes, and go again the light never turns off Again. Kinda getting over messing with this thing!
CP241 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 EZGO TXT losing prime Gas EZGO
robin 295 oil pump prime Gas EZGO
oil pump prime Gas EZGO
EZGO gas cart losing prime Gas EZGO
Loss of fuel prime Gas EZGO


All times are GMT -5. The time now is 06:37 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.