lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-08-2019, 09:27 AM   #1
Not Yet Wild
 
Join Date: Apr 2019
Posts: 7
Default 2002 TXT issue (solenoid?)

Hello,

I am trying to figure out what is going on with my 2002 EZGO TXT, last year I went to drive it and it was complete dead, would not move, no clicking from solenoid. I finally got back to it this year. I replaced the solenoid and still get nothing, I have 12 volts on the c and d terminals with the peddle pressed.

I checked the fuse, it is good. The reverse buzzer is working. I am wonder what would be the next thing to look at?

Thanks!
gregorys7717 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-08-2019, 09:35 AM   #2
Gone Wild
E-Z-GO
 
Join Date: Feb 2019
Location: North Florida
Posts: 258
Default Re: 2002 TXT issue (solenoid?)

Just realized this is a gas cart.
Brob1969 is offline   Reply With Quote
Unread 04-08-2019, 10:06 AM   #3
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 493
Default Re: 2002 TXT issue (solenoid?)

Starter brushes maybe if you are 100 % sure you grounds are good and you got 12 volts going to starter when you push pedal.

Is so then tap the starter lightly and see if it will start. You can test starter using jumper cables to starter. Positive cable to F2 on starter and just ground the negative cable on the ground terminal on starter.
trig123 is offline   Reply With Quote
Unread 04-08-2019, 01:11 PM   #4
Not Yet Wild
 
Join Date: Apr 2019
Posts: 7
Default Re: 2002 TXT issue (solenoid?)

Quote:
Originally Posted by trig123 View Post
Starter brushes maybe if you are 100 % sure you grounds are good and you got 12 volts going to starter when you push pedal.

Is so then tap the starter lightly and see if it will start. You can test starter using jumper cables to starter. Positive cable to F2 on starter and just ground the negative cable on the ground terminal on starter.
I do not hear any clicking from the solenoid, is that right? I will try and by pass and go directly to the starter. Should I be getting 12V to F2 on the starter when the pedal is pressed down?
gregorys7717 is offline   Reply With Quote
Unread 04-08-2019, 01:29 PM   #5
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 493
Default Re: 2002 TXT issue (solenoid?)

Quote:
Originally Posted by gregorys7717 View Post
I do not hear any clicking from the solenoid, is that right? I will try and by pass and go directly to the starter. Should I be getting 12V to F2 on the starter when the pedal is pressed down?
Yes. Battery voltage to F2 when pedal is pushed with key on.
Also you should hear that click from solenoid when you push pedal.

You have two small terminals on the solenoid. One is ground . Take a jump wire and go from negative side of battery to the one that is grounded. If it clicks then you have grounding issues. You can't miss it as it is the only small terminal that has one black wire on it.

The other small terminal has 12 volts when you push pedal. Three wires going to it.
Do you hear the micro switch click when you push pedal ?

EZGO installed these male terminals on the solenoids where you can just push the wire terminal on. I have seen people leave these terminals off. Next person that installs say a voltage regulator or ignitor and not have these male terminals will twist the small nut and break the solenoid inside.

There are two nuts on each small terminals if you look. You will have to hold the bottom nut with a thin 5/16th end wrench . If one doesn't do this then you sometimes will break it like I said inside the solenoid. I have actually took them apart and soldered them.

I included a crude picture of how it is supposed to work
Attached Images
File Type: jpg my cart.jpg (219.7 KB, 0 views)

Last edited by trig123; 04-08-2019 at 03:11 PM.. Reason: more info
trig123 is offline   Reply With Quote
Unread 04-09-2019, 07:21 PM   #6
Not Yet Wild
 
Join Date: Apr 2019
Posts: 7
Default Re: 2002 TXT issue (solenoid?)

Thank you so much! We have made progress :D
She turns over now! But won't start, I tried to use some starting fluid to see if was a carb issue and no go. I checked the wires to the coil and I am getting 9.3 V on one and 1.3 on the other. (Before the coil) Does that make any sense? I pulled the plug off and turned it over, i am not seeing any spark.
gregorys7717 is offline   Reply With Quote
Unread 04-09-2019, 07:38 PM   #7
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 493
Default Re: 2002 TXT issue (solenoid?)

What did you find on why it would not turn starter over ?
Connect a test light to one of the terminals on coil and turn it over. See if your test light is flashing
trig123 is offline   Reply With Quote
Unread 04-09-2019, 07:56 PM   #8
Not Yet Wild
 
Join Date: Apr 2019
Posts: 7
Default Re: 2002 TXT issue (solenoid?)

Bad ground! UGH LOL! your picture made me retest all of my connections, Test light stays on solid on both terminals
gregorys7717 is offline   Reply With Quote
Unread 04-10-2019, 10:01 AM   #9
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 493
Default Re: 2002 TXT issue (solenoid?)

If all is correct then with two wires that plug on male terminals of coil connected then your test light will flash when spinning over.

I just pull the wires off enough so they still make contact with coil terminals and stick a test light on it.

There is a black wire with white stripe that comes from ignitor. It has to be grounded. I think my picture showed it. I will show updated picture with wire that needs grounded from ignitor . If not correctly grounded then your test light will not flash.

Check that and post back. I have seen many a time that ground wire come off or not pushed on good enough to make a ground.
Attached Images
File Type: jpg ezgo wiring.jpg (234.0 KB, 0 views)
trig123 is offline   Reply With Quote
Unread 04-10-2019, 04:55 PM   #10
Not Yet Wild
 
Join Date: Apr 2019
Posts: 7
Default Re: 2002 TXT issue (solenoid?)

Hello again! Thank you for helping me figure this out, it is VERY much appreciated! So I checked the black wire with the white stripe, it seems to be good.

I put the test light on the coil, on one of the terminals I get one blink and nothing more, on the other terminal i get a solid light when turning over the engine.

I also bought an inline tester for the spark plugs (https://www.harborfreight.com/In-Lin...ker-63590.html) , I get nothing on either plug when I plug this in to either plug. Bad coil?

I did see a loose wire (white) behind the coil that isn't attached to anything (I don't believe it ever was).


gregorys7717 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 DS Electrical Issue Electric Club Car
2002 TXT Speed Issue Help Gas EZGO
2002 TXT starting issue Gas EZGO
2002 CC(gas) - Acceleration issue Gas Club Car
solenoid for 2002... Electric Club Car


All times are GMT -5. The time now is 09:54 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.