lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-15-2019, 04:24 PM   #1
Gone Wild
 
tguellich's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: Born and raised in the state of Confusion
Posts: 150
Default 92 2-cycle Confusing Issues

I learned all I know from this site and it has served my cart so well. But I have recently hit a wall. The cart was running great in the winter and I had taken 2 friends out for a ride. After about 10 minutes she sputtered to a stop. Would still turn over fine, just no go. Got it home and started looking into it. It had been years since I did much work to it so right off the bat I replaced fuel filter, fuel pump, HEI module, coil, and plug. Still the same result.

1 - I put a spark tester on it and it is a strong initial spark then no spark at all. What could that be?

2 - I have the air filter off the carb and I am not smelling a ton of gas nor is there any on the plug.

I just can't tell if this is a spark issue, a fuel issue, or something else. Any ideas where I need to look with this thing? I was thinking of a carb cleaning as I haven't done it in 5 years or so since I bought the new carb. But after that I am totally confused.
tguellich is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-15-2019, 06:06 PM   #2
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,443
Default Re: 92 2-cycle Confusing Issues

Quote:
Originally Posted by tguellich View Post

2 - I have the air filter off the carb and I am not smelling a ton of gas nor is there any on the plug.
.
You can see if it's a fuel problem by pulling the gas line off the carb and see if it's pulsing gas, could also be a stuck needle valve in the float bowl from this crap ethanol that they add to the gas.
StoveBolt is offline   Reply With Quote
Unread 04-15-2019, 08:32 PM   #3
Gone Wild
 
tguellich's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: Born and raised in the state of Confusion
Posts: 150
Default Re: 92 2-cycle Confusing Issues

Quote:
Originally Posted by StoveBolt View Post
You can see if it's a fuel problem by pulling the gas line off the carb and see if it's pulsing gas, could also be a stuck needle valve in the float bowl from this crap ethanol that they add to the gas.
It is pulsing fuel. I checked. I only use non-eth gas but its been a long time so I am going to remove and clean the carb next.

Any ideas on the spark? It should continue to spark, right? Not just a single one when I first tap the pedal?
tguellich is offline   Reply With Quote
Unread 04-15-2019, 10:19 PM   #4
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 665
Default Re: 92 2-cycle Confusing Issues

Are you saying this cart has been converted to HEI ?
trig123 is online now   Reply With Quote
Unread 04-16-2019, 06:41 AM   #5
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 665
Default Re: 92 2-cycle Confusing Issues

If the ignitor is bad you usually get one spark. Probably same things applies to HEI modules. Try another one if you did convert to HEI
trig123 is online now   Reply With Quote
Unread 04-16-2019, 08:00 AM   #6
Gone Wild
 
tguellich's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: Born and raised in the state of Confusion
Posts: 150
Default Re: 92 2-cycle Confusing Issues

Quote:
Originally Posted by trig123 View Post
Are you saying this cart has been converted to HEI ?
It has been converted and that was the first thing I replaced. Same result.
tguellich is offline   Reply With Quote
Unread 04-20-2019, 04:22 PM   #7
Gone Wild
 
tguellich's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: Born and raised in the state of Confusion
Posts: 150
Default Re: 92 2-cycle Confusing Issues

I am still at a loss. My volt meter isn't seeing the pulsar put out any ac current while turning over but I tested a running cart and got the same result. I know I'm only getting an initial spark then no other so I ordered another new hei module and a solenoid just to be sure that's not the issue. The only other thing could be the pulser, right? Is there anything I'm forgetting? I hear an initial click to the solenoid, get a single spark, and it turns over forever, just no combustion.
tguellich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
90 ezgo 2 cycle fuel pump issues Gas EZGO
Rear suspension on 88 gas cc ds confusing me Gas Club Car
Confusing wiring diagrams Electric EZGO
1988 Marathon 2 cycle issues Gas EZGO
Clutches are confusing Big Block Talk!


All times are GMT -5. The time now is 05:43 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.