lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-10-2019, 05:36 PM   #1
Not Yet Wild
 
Join Date: Apr 2019
Posts: 6
Default 2000 EZGO Workhorse 1200 Gas poor performance under load

I have a 2000 EZGO Workhorse Gas with the 295cc Robin gas engine. I bought it as a fixer upper and have replaced some parts on it. I replace the driven clutch with the "high torque" model and also replaced the drive belt. When the cart is jacked up it accelerates fine or when you are traveling downhill. When the cart is under a load it barely moves along. The drive clutch seems to be working correctly while the cart is jacked up. What are some things to check? I appreciate any assistance that I might get.
acanterbury is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-10-2019, 06:27 PM   #2
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,518
Default Re: 2000 EZGO Workhorse 1200 Gas poor performance under load

I would start by adjusting the valves and It's a 350 Robins unless someone changed the motor.
StoveBolt is online now   Reply With Quote
Unread 05-10-2019, 07:32 PM   #3
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,664
Default Re: 2000 EZGO Workhorse 1200 Gas poor performance under load

Quote:
Originally Posted by StoveBolt View Post
I would start by adjusting the valves and It's a 350 Robins unless someone changed the motor.
Agreed. And a compression test before and after. Valve issues are very common on these because nobody ever adjusts them...
CP241 is offline   Reply With Quote
Unread 05-26-2019, 05:12 PM   #4
Not Yet Wild
 
Join Date: Apr 2019
Posts: 6
Default Re: 2000 EZGO Workhorse 1200 Gas poor performance under load

Thanks for the info. I ended up having to replace a faulty ignition coil. I did adjust the valves as well. Compression was around 150psi on both cylinders.
acanterbury is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Brush Guard for 2000 EZGO Workhorse 1200 LX Gas EZGO
2000 ezgo workhorse 1200 Electric EZGO
2000 EZGO Workhorse 1200 LX Wiring Diagram Gas EZGO
2000 Ezgo Workhorse 1200 Golf Carts and Parts


All times are GMT -5. The time now is 07:02 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.