lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-10-2019, 11:19 PM   #1
Not Yet Wild
 
BigRed77's Avatar
E-Z-GO
 
Join Date: Nov 2009
Location: Horseshoe Bay, Texas
Posts: 69
Default 2002 wont crank when hot

2002 gas marathon
Runs fine for several short stop and goes, but if we run far enough to really warm up the engine and stop, it wont start
Like step on the pedal and nothing, as if the key was off
Wait around for about 15 minutes and try again and everything is fine

Even tested just driving around for probably 20 minutes straight with no full stops and it ran fine
Then one full stop and it acted the exact same
Let it cool and it starts fine

Any ideas?

I thought starter at first and tried tapping the starter with a rock, but that didnt seem to help
BigRed77 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-10-2019, 11:29 PM   #2
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,867
Default Re: 2002 wont crank when hot

Locate the solenoid, next to the battery. It's on that vertical plate between the battery and the wall. Theres 2 bug terminals and 2 little ones. Use a meter and hook the black lead to 1 terminal the the red lead to the other.it should show 12 volts when the pedal is depressed and 0 volts when the pedal is released.

Then check the 2 large lugs. 1 will read 12v so
All the time. The other will read 0 volts with the pedal released and 12v with the pedal pressed down. If the first check tests good, but you have 0 volts on the 2nd large lug when you press the pedal (you should also hwar/feel the solenoid click) then the solenoid is bad and needs to be replaced
CP241 is online now   Reply With Quote
Unread 07-11-2019, 11:46 AM   #3
Not Yet Wild
 
BigRed77's Avatar
E-Z-GO
 
Join Date: Nov 2009
Location: Horseshoe Bay, Texas
Posts: 69
Default Re: 2002 wont crank when hot

Quote:
Originally Posted by CP241 View Post
Locate the solenoid, next to the battery. It's on that vertical plate between the battery and the wall. Theres 2 bug terminals and 2 little ones. Use a meter and hook the black lead to 1 terminal the the red lead to the other.it should show 12 volts when the pedal is depressed and 0 volts when the pedal is released.

Then check the 2 large lugs. 1 will read 12v so
All the time. The other will read 0 volts with the pedal released and 12v with the pedal pressed down. If the first check tests good, but you have 0 volts on the 2nd large lug when you press the pedal (you should also hwar/feel the solenoid click) then the solenoid is bad and needs to be replaced
unfortunately this is the road I've been running down
a few weeks ago, I thought I had determined my solenoid was bad, got on Amazon and ordered one without doing much reading reviews, it came in and I installed it and all was well
it wasnt a direct fit and had to make some new holes to make it mount, but it worked.... in my figuring how to mount it, I came across a bunch of reviews that said it was crap and only lasted a short time
SO, Ffwd to last saturday when the cart suddenly quit on me, I quickly assumed it was the poor quality replacement solenoid and ordered one from buggies unlimited
it came yesterday and I put it on, and ended up with the description of what happened in the OP

I'll put the volt meter on it tonight,
I am in doubt just to think I could have gotten two bad solenoids in a row, but maybe I am just unlucky
BigRed77 is offline   Reply With Quote
Unread 07-11-2019, 12:00 PM   #4
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,867
Default Re: 2002 wont crank when hot

the junk Nivel buggies unlimited solenoid is no better than the junk solenoid you got from Amazon (and a very good chance they are the exact same solenoid. I'd bet 70% of the aftermarket parts on ebay and amazon are the Nivel products sold by different sellers, BU is Nivel). So it would not surprise me in the least if it were bad right out of the box.

Verify with a meter first to make sure, but if I were a betting man I would say you'll want to buy an OEM solenoid.

For a TXT I can't find just the solenoid itself, only the plate with the ignitor and everything. IT's expensive.

https://shop.txtsv.com/electrical-pl...embly-72909g01


However, you should be able to use this one and make it work. A solenoid is just an electromagnetic switch. You've got your 2 small terminals that are your coil. When energized, they close the main switch contacts. And the 2 big terminals that run to either side of the switch contacts. In the cheap solenoids, everything is cheap. coil is weak, the contacts are not heavy duty enough to supply the current demand and burn up. This coming directly from ezgo isn't the "TXT Solenoid" but you know the quality will be there. It says it fits 2stroke and 4 cycle marathons (the 4 cycle marathon was the same 295 engine your TXT has). and is much cheaper than the entire plate assembly.

https://shop.txtsv.com/12-volt-solen...-z-go-marathon
CP241 is online now   Reply With Quote
Unread 07-11-2019, 06:34 PM   #5
Not Yet Wild
 
BigRed77's Avatar
E-Z-GO
 
Join Date: Nov 2009
Location: Horseshoe Bay, Texas
Posts: 69
Default Re: 2002 wont crank when hot

Quote:
Originally Posted by CP241 View Post
Locate the solenoid, next to the battery. It's on that vertical plate between the battery and the wall. Theres 2 bug terminals and 2 little ones. Use a meter and hook the black lead to 1 terminal the the red lead to the other.it should show 12 volts when the pedal is depressed and 0 volts when the pedal is released.

Then check the 2 large lugs. 1 will read 12v so
All the time. The other will read 0 volts with the pedal released and 12v with the pedal pressed down. If the first check tests good, but you have 0 volts on the 2nd large lug when you press the pedal (you should also hwar/feel the solenoid click) then the solenoid is bad and needs to be replaced
Ok. So this is while it's still cold (so the engine is cranking)
Reading across both big lugs, I get 12V BEFORE pressing the pedal
Press the pedal and it drops to zero before the engine starts then goes all over the place depending on where I let it rev to

One lug to ground reads 12V all the time, the other reads 0V then goes to 12V when pedal is pressed

Since the engine is cool, I'm gunna go run around the neighborhood and only stop close to home, hoping I can time it right then check with the meter when it's not wanting to start
BigRed77 is offline   Reply With Quote
Unread 07-11-2019, 06:57 PM   #6
Not Yet Wild
 
BigRed77's Avatar
E-Z-GO
 
Join Date: Nov 2009
Location: Horseshoe Bay, Texas
Posts: 69
Default Re: 2002 wont crank when hot

Well that didnt take long, didnt make it out of the driveway
Now I still show 12v between the two big terminals without the pedal pressed, and it drops to zero when pedal is pressed
One lug shows 12V both when pressed or not
The other shows 0V when not pressed and it only shows 3v when the pedal is pressed

So conclusion, I got a **** *** solenoid twice in a row.....? Agree?
BigRed77 is offline   Reply With Quote
Unread 07-11-2019, 09:51 PM   #7
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 2,314
Default Re: 2002 wont crank when hot

You can't read voltage in line like that.
Put one meter probe on the negative post of the battery. Leave it there.

One large solenoid lug will always read 12 volts because it is directly connected to the positive battery post.

Put the red probe on the other large solenoid lug. It should read zero until you step on the pedal. Stepping on the pedal should make it read 12 volts.

If it does consistently, move down the line towards your starter.
cart around is offline   Reply With Quote
Unread 07-12-2019, 09:20 AM   #8
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 2,314
Default Re: 2002 wont crank when hot

It was too late for me to edit, so I will add on here.

EDIT: I will slightly revise this.
You can see a one, or two volt drop when stepping on the pedal, but no more.
We also need to establish that a fully charged battery is 12.7 volts. 11.9 volts is a dead battery.
cart around is offline   Reply With Quote
Unread 07-12-2019, 02:19 PM   #9
Not Yet Wild
 
BigRed77's Avatar
E-Z-GO
 
Join Date: Nov 2009
Location: Horseshoe Bay, Texas
Posts: 69
Default Re: 2002 wont crank when hot

ahh, thank you
I will check again
BigRed77 is offline   Reply With Quote
Unread 07-12-2019, 02:26 PM   #10
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 2,867
Default Re: 2002 wont crank when hot

This may help you now and in the future. It's probably more information than you really need, but knowledge never hurts!

http://www.buggiesgonewild.com/gener...ultimeter.html
CP241 is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
engine wont crank Gas Yamaha
wont crank, new solenoid Gas Club Car
wont crank Gas Club Car
cart wont crank Gas Club Car
Ezgo gas wont crank Gas EZGO


All times are GMT -5. The time now is 06:03 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.