lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-23-2019, 05:09 PM   #11
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2019
Location: SE USA
Posts: 8
Default Re: Cart runs cold, not hot

OK, so cart does not run cold now either. I cleaned the rust off the plate, etc like you suggested. No change. I checked the primary and secondary coil, all good per manual on ohms. So it's gotta be the ignitor. Is there anything I can do beside spending $500 on a new one!
Rvrdvr is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-10-2019, 09:33 AM   #12
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2019
Posts: 26
Default Re: Cart runs cold, not hot

Borrow one to test if it changes anything.

How did it work out for you?

EZGO 2001 TXT Shuttle 2+2 350cc

https://we.tl/t-pHBddHNfPD?src=dnl

I’m having my share of issues, any advice anyone?
BuggyHunter is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
runs better in cold weather Gas Yamaha
88 runs great cold not when hot. need help Gas EZGO
g14 runs slow when cold Gas Yamaha
g16 runs good cold but not when hot Gas Yamaha
runs good cold runs bad hot? Gas EZGO


All times are GMT -5. The time now is 07:37 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.