lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-07-2019, 01:56 PM   #1
Not Yet Wild
 
Join Date: Oct 2019
Posts: 7
Default Only starts when lightly pressed

I have an EZGO TXT 99 and 01. I have been working on them for years and pretty knowledgeable but man do I need some help with this one. The 99 TXT has always preferred the gas pedal be slowly pressed in order to start. Five years ago it started preferring to be pressed slowly and only half way. Now you have to barley press the gas in order for it to take. Runs awesome without skipping a beat when you going and usually starts much better after a little warm.

Over the years I have always set the valves yearly and replaced air fuel and spark plugs about every other. I have even played around with .004 to .006 on the valves to see if that would help. I have cleaned the carburetor and both jets plenty of times hoping that was the case. It may have helped but never fixed the issue.

I have above 150 in both cylinders. New spark plugs, coil is only 3 years old, new air filter, new fuel filter, cleaned carb and jets, set valves and triple check them. Fuel pump is newer and spitting good.

Anyone have any ideas? It almost seems like the fuel and fire are good but either air in or air out is restricted. Maybe muffler since it gradually got worse intake has been checked as well as trying to fire intake box completely open

Appreciate any help!
Gasman24 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-07-2019, 03:20 PM   #2
Gone Wild
 
Timberwolflt's Avatar
E-Z-GO
 
Join Date: Sep 2017
Location: South Texas
Posts: 266
Default Re: Only starts when lightly pressed

Sounds to me like you may have a vacuum leak or extra air slipping in somewhere... Maybe the butterfly shaft has worn a little gap or something... maybe a gasket going bad...

I’d put it on jack stands and run it while squirting a little carb cleaner or starting fluid around the carb and intake and see if you notice any engine speed changes... being careful not to get any in the intended intake
Timberwolflt is offline   Reply With Quote
Unread 10-07-2019, 03:41 PM   #3
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 3,443
Default Re: Only starts when lightly pressed

I would suspect a throttle cable adjustment. Make sure the throttle cable does NOT move before the starter/generator starts spinning. You SHOULD be able to run JUST the S/G without actually starting the cart by pressing the pedal only a little bit (cart won't run though because throttle is closed and no air going in).

If the carb/throttle starts to open too early, then by the time the S/G starts to spin, the carb is at a much more "open" position than it should be (just to throw out a number, we'll say 1/4 throttle), so it will be harder to start. Choking may help some, depending on how far out of adjustment it is. This would also explain why it will start if you slowly and lightly press the pedal down (less throttle open) and also why it runs great once it starts running.

Out of adjustment cable will also affect low speed operation. I set mine so I literally have a "crawl" speed... I could get out and walk faster than the cart is driving if I had a way to hold the gas pedal down.
CP241 is offline   Reply With Quote
Unread 10-09-2019, 02:31 PM   #4
Not Yet Wild
 
Join Date: Oct 2019
Posts: 7
Default Re: Only starts when lightly pressed

Thank you for the replies,

I will not be back up at camp to try these suggestions for a few weeks but I will let you know how I make out. I believe I have the carb assembly pretty well air tight. Gaskets have been replaced and touched up with a small amount of sealer. I have never looked or checked the throttle cable so excited to see if that may be the issue. The starting condition has definitely gotten worse over the years. You wouldn't think anything was wrong by how it runs whether crawling or making dust. I was going to buy a new factory carb but I just don't think that is it.

Open to any other suggestions.

Thanks again
Gasman24 is offline   Reply With Quote
Unread 10-09-2019, 02:57 PM   #5
Not Yet Wild
 
Join Date: Oct 2019
Posts: 7
Default Re: Only starts when lightly pressed

Thank you for the replies,

I will not be back up at camp to try these suggestions for a few weeks but I will let you know how I make out. I believe I have the carb assembly pretty well air tight. Gaskets have been replaced and touched up with a small amount of sealer. I have never looked or checked the throttle cable so excited to see if that may be the issue. The starting condition has definitely gotten worse over the years. You wouldn't think anything was wrong by how it runs whether crawling or making dust. I was going to buy a new factory carb but I just don't think that is it.

Open to any other suggestions.

Thanks again
Gasman24 is offline   Reply With Quote
Unread 11-21-2019, 11:17 AM   #6
Not Yet Wild
 
Join Date: Oct 2019
Posts: 7
Default Re: Only starts when lightly pressed

Help getting pissed!!!!! So I have an update. Backing off the throttle cable helped a little as it gave me an even lighter touch to the gas. I confirmed no air leaking around carburetor pulled and cleaned it as well as made sure of gaskets and tight seal. I did buy a cheap carburetor off eBay just to try it and everything operated mostly the same if not worse. Keep in mind once this things starts it runs great. You just have to be extremely light with the peddle.

I have two of these carts for over 13 years now and have been able to tackle just about everything with them, but I am getting frustrated now. There isn't much left to check. Although not normal I was even thinking possible clog muffler but the pressure coming out seems good. The one thing I did notice is when I connected it to the battery charger it turned over a little quicker. Is it possible the battery is just a little under and not cranking over the starter as fast as it should? Maybe starter getting old? I replaced the battery a few years ago I didn't give it much thought I got the biggest highest cranking amps I could fit. Do you guys have a battery suggestion?

I have replaced fuel pump, plugs, ignition coil, carburetor, as well as set and checked the vales a bunch of times. Any help is appreciated.
Gasman24 is offline   Reply With Quote
Unread 11-21-2019, 12:26 PM   #7
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 922
Default Re: Only starts when lightly pressed

If I would have to guess I would say you intake valves are sinking in head. Remove the valve cover, take a close up of your valve springs and post them here. I would like to see how many more threads are showing on the intakes. For these engines to perform top notch you need 170 pounds of compression. Post that picture
Here is what the underside looks like
Attached Images
File Type: jpg intake sunk in head.jpg (117.4 KB, 0 views)
File Type: jpg IMG_0482.jpg (287.8 KB, 0 views)
trig123 is offline   Reply With Quote
Unread 11-21-2019, 12:36 PM   #8
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,617
Default Re: Only starts when lightly pressed

No help here, but I have had that trouble with a couple 295s and the one I have now. I find it best to hold the choke out and peddle to the floor for 10 seconds or so then raise the peddle to almost an idle.. starts every time.
StoveBolt is offline   Reply With Quote
Unread 11-21-2019, 01:50 PM   #9
Not Yet Wild
 
Join Date: Oct 2019
Posts: 7
Default Re: Only starts when lightly pressed

I will be backup at camp in a few weeks and can take a look at the intake valves. The problem has gotten progressively worse over the years. usually after it starts once and runs for awhile it starts much better. Always runs good just starting issues. I am grasping now but is there anyway to cut back or adjust the amount of fuel it is getting on initial start up? When it has trouble starting I do smell fuel pretty quickly. I have to let it sit some times to avoid flooding. Again, I really appreciate all and every suggestion that I am given.
Gasman24 is offline   Reply With Quote
Unread 11-26-2019, 05:46 AM   #10
British and proud
 
Cartmaster's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: United Kingdom
Posts: 657
Default Re: Only starts when lightly pressed

Quote:
Originally Posted by Gasman24 View Post
. When it has trouble starting I do smell fuel pretty quickly.
Thats pretty much confirming the valves are sunk in. If you do a compression test dry, then wet, you will be certain.
Cartmaster is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2004 DS starts than dies when accelerator is pressed Gas Club Car
2013 Club Car DS Only Starts With Pedal Pressed Half Way Gas Club Car
1996 Club car carryall only starts when gas is barely pressed Gas Club Car
*Lightly Used* CVTech Series 06 CVT Clutch - $199 Shipped Golf Carts and Parts
club car has f/r w/o acc.pressed Electric Club Car


All times are GMT -5. The time now is 02:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.