lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-28-2019, 03:29 PM   #1
Not Yet Wild
 
Join Date: Oct 2019
Posts: 4
Default 2002 TXT - Dead?

I am not sure whats going on with my 2002 txt.
Battery - good
Solenoid is clicking
Spark on both plugs

When I press the pedal, i get nothing besides the Solenoid clicking...

any thoughts would be much appropriated.

Last edited by gregorys77; 10-28-2019 at 03:30 PM.. Reason: Edit
gregorys77 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-28-2019, 04:02 PM   #2
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 3,358
Default Re: 2002 TXT - Dead?

Grab the primary clutch by hand and turn it a half turn or so and try again. Or try to push it when you press the gas pedal (or have someone push you) and press the gas pedal. If it starts running then, chances are the brushes are worn in your starter/generator.

If the solenoid is clicking then everything in front of the solenoid should be okay. Possible the solenoid is clicking but not actually making contact internally to pass power through, or maybe a bad ground on the plate the solenoid mounts to... but first I would try and see if turning the engine by hand a little bit makes the starter work. easy to test, and easy to replace the brushes in the starter/gen if they are worn out.
CP241 is offline   Reply With Quote
Unread 10-28-2019, 04:29 PM   #3
Not Yet Wild
 
Join Date: Oct 2019
Posts: 4
Default Re: 2002 TXT - Dead?

i'll give that a shot!

I had issues with it last year, it ended up being I needed to spray electrical cleaner in the plastic plug connections, they had a green \ rusty color.

The solenoid is new a few months ago. When the gas is pressed I get a light on the test light for both posts on the solenoid
gregorys77 is offline   Reply With Quote
Unread 10-28-2019, 04:35 PM   #4
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 3,358
Default Re: 2002 TXT - Dead?

I would recommend a meter... A test light coming on just means there "is" voltage. It may be 2 volts it may be 12 volts, there's no way to know. A meter doesn't lie

You can also pull one of the rubber covers off of the starter/generator. This page has some great pictures of what to look for https://www.golfcarcatalog.com/golf-...rator-brushes/
CP241 is offline   Reply With Quote
Unread 12-01-2019, 05:43 PM   #5
Not Yet Wild
 
Join Date: Oct 2019
Posts: 4
Default Re: 2002 TXT - Dead?

so i got some time to look at this again... I pulled the rubber cover and the brushes look fine from the top, they were plenty sticking out. I checked with a meter and i wasen't getting any voltage to to the starter. I seemed to get that fixed...

The motor turns over now, i show spark with a test light between the spark plug and boot but it will no start, i even tried a little starting fluid and it will won't fire. any ideas?
gregorys77 is offline   Reply With Quote
Unread 12-01-2019, 07:40 PM   #6
lost in the woods
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 3,358
Default Re: 2002 TXT - Dead?

Hold the spark plug against one of the valve cover boots and watch the spark. What color is it?
CP241 is offline   Reply With Quote
Unread 12-01-2019, 08:56 PM   #7
Not Yet Wild
 
Join Date: Oct 2019
Posts: 4
Default Re: 2002 TXT - Dead?

I didn't see any spark, i put the spark plug tester light back on and i only get 1 flicker when pressing on the gas and then letting off... my other question is I have this wire that i had to to make a make up wire, i don;t get any voltage off it when pressing the gas. What wire is this to?

Its the red \ white wire with the make up black wire on the open ends (attached)
Attached Images
File Type: jpg greg123.jpg (96.1 KB, 0 views)
gregorys77 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 Club Car DS gas.....dead Gas Club Car
2002 gas battery went dead Gas Club Car
2002 Lifted PDS DEAD Electric EZGO
Brought a 2002 PDS back from the dead On Road Golf Carts!
Help! 2002 CC Regen Dead Electric Club Car


All times are GMT -5. The time now is 05:31 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.