lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-27-2009, 07:32 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2009
Location: Burstall, Saskatchewan Canada
Posts: 13
Default Reverse...runs awesome Forward..runs bad

Excellent site people...best I have been to regarding carts. Well I have a dilema that started yesterday, cart is an Ezgo TXT 1986 with a EC25 2PG (complete rebuild this spring) had oil injection but removed it and started mixing my fuel(50:1) (that was the reason for the COMPLETE rebuild,oil pump quit) It ran good all year but yesterday in the middle of a game it just started to spit and spudder so I stopped it for a second and now it is very slow to start moving (no low end power)smokes alot and sounds like it is not firing properly. In reverse it takes off and runs awesome with LOTS of low and high end power. Talked with my mechanic and he laughed and told me definetly when I asked if he installed the piston in correctly. I know nothing about the timing or points on this engine....are there 2 sets of points? Where do I start to diagnose this problem? Any help would be appreciated. Thanks
topdrive is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-27-2009, 08:43 AM   #2
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,431
Default Re: Reverse...runs awesome Forward..runs bad

I think if it runs fine in reverse, we can eliminate any compression issues? But it would be nice to have a reading .... someone with more 2 stoke knowledge will be along soon....
scottyb is offline   Reply With Quote
Unread 09-27-2009, 08:50 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2009
Location: Burstall, Saskatchewan Canada
Posts: 13
Default Re: Reverse...runs awesome Forward..runs bad

Quote:
Originally Posted by scottyb View Post
I think if it runs fine in reverse, we can eliminate any compression issues? But it would be nice to have a reading .... someone with more 2 stoke knowledge will be along soon....
I will take a comp this morning.......Thank you for your comment Scotty.
topdrive is offline   Reply With Quote
Unread 09-27-2009, 08:59 AM   #4
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Reverse...runs awesome Forward..runs bad

More info would be nice.

Question - What did your laughing mechanic say about the issue?

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 09-27-2009, 10:01 AM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2009
Location: Burstall, Saskatchewan Canada
Posts: 13
Default Re: Reverse...runs awesome Forward..runs bad

Quote:
Originally Posted by mikesmotortoys View Post
More info would be nice.

Question - What did your laughing mechanic say about the issue?
I guess I should have said " My Ex mechanic" we had a little (heated)disccusion after it took him almost 3 months + 2x the $$$$ he quoted me to rebuild the engine so the laughing mechanic just laughed.

As for the more info.....what info should I include? Thanks for your input......I need all I can get.
topdrive is offline   Reply With Quote
Unread 09-27-2009, 10:12 AM   #6
Gone Wild
 
tonyton's Avatar
E-Z-GO
 
Join Date: Jan 2009
Location: Alabama
Posts: 2,120
Default Re: Reverse...runs awesome Forward..runs bad

These motors retard the timing to spin the motor backwards for reverse. They advance to spin the motor forward. It soumds like it's retarding the timing past TDC to get the high speed reverse and in turn won't advance BTDC to get your forward speed.
I know how they work but have never owned one. I'll reveiw the ignition wiring diagram and see what it could be. I think these are CDI ignition systems (no points).
If the piston was backwards it wouldn't start.
tonyton is offline   Reply With Quote
Unread 09-27-2009, 10:45 AM   #7
Gone Wild
 
tonyton's Avatar
E-Z-GO
 
Join Date: Jan 2009
Location: Alabama
Posts: 2,120
Default Re: Reverse...runs awesome Forward..runs bad

This what I'm looking athttp://www.bennettgolfcars.ca/parts.php"

Your '86 should have one set of points and a condensor. The F and R switch electrically changes the direction of the starter. If your starter/generator are turning the appropriate direction in conjunction with the FR switch it would probably be the points. There's not a lot else there it could be. The manual is only parts, you need to find where and what to set new points at. You may need to call a dealer that has this info. We don't have a tech manual for that model...
This is an educated guess. It's the best I could do with what we have.
Hopefully someone that owns one can shed some light on this and verify that as the problem...
Wish I could be of more help....tony

Last edited by tonyton; 09-27-2009 at 11:11 AM.. Reason: Add info
tonyton is offline   Reply With Quote
Unread 09-27-2009, 08:02 PM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2009
Location: Burstall, Saskatchewan Canada
Posts: 13
Default Re: Reverse...runs awesome Forward..runs bad

Thanks for the info Tony, much appreciated. I may just spend the $70.00 and buy a service manual. Do I need to pull the engine to change points or can I do it without? Thanks again.
topdrive is offline   Reply With Quote
Unread 09-27-2009, 11:05 PM   #9
Gone Wild
 
tonyton's Avatar
E-Z-GO
 
Join Date: Jan 2009
Location: Alabama
Posts: 2,120
Default Re: Reverse...runs awesome Forward..runs bad

If nobody else can shed some light on this, you may need the manual. I hate to say that but I can't find what I need to see. After reveiwing the diagrams, I can't honestly say that it has points or not. There are parts till '86 but our schematics have a lapse of several years, and I noticed that was one of them.
If you get a manual and feel like sharing any info it would be appreciated. It would help us help others in the future. Again, I apologize that I couldn't get all the proper info for you.
One thing that you could test is the microswitch. Take the forward wires and place them on the reverse microswitch. Put the cart in reverse (it should go forward) and see if it runs. If it runs better the forward microswitch is faulty. Good Luck. tony
tonyton is offline   Reply With Quote
Unread 09-27-2009, 11:31 PM   #10
Getting Wild
 
roxyrose08's Avatar
Club Car
 
Join Date: Sep 2009
Location: vernon b.c. canada
Posts: 93
Default Re: Reverse...runs awesome Forward..runs bad

i have this exact cart! i just got it last week and i notice that it runs much better in reverse. i was under the impression that it was because it did not charge in reverse and therefore no load was hindering it in reverse but now i am rethinking this whole problem. i hope someone has the answer to our problem.
roxyrose08 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO runs in reverse, not forward Gas EZGO
Runs 10 minutes then shuts off, wait 5 then runs again... Electric EZGO
91 EZ-GO Marathon Runs in Reverse ONLY Electric EZGO
1994 Ezgo electric runs great in reverse but does not forward Electric EZGO
G1 runs in forward no fire in reverse Gas Yamaha


All times are GMT -5. The time now is 01:03 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.