lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-07-2010, 08:53 AM   #1
Not Yet Wild
 
Join Date: Jan 2009
Posts: 18
Default not firing

I have a 1994 ezgo marathon 295 cc. I am getting plenty of spark and gas.
I did replace the factory exhaust with a performance exhaust. do I need to replace the carb jet or are therr any adjustments that can be made to the carb. I have installed a new factory carb, igniter, voltage reg., ignition coil and pulsar coil. Have solenoid ordered.
shoprocket is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-07-2010, 09:46 AM   #2
Gone Wild
 
big mule's Avatar
E-Z-GO
 
Join Date: Aug 2009
Location: Santuck,Al
Posts: 1,580
Default Re: not firing

Quote:
Originally Posted by shoprocket View Post
I have a 1994 ezgo marathon 295 cc. I am getting plenty of spark and gas.
I did replace the factory exhaust with a performance exhaust. do I need to replace the carb jet or are therr any adjustments that can be made to the carb. I have installed a new factory carb, igniter, voltage reg., ignition coil and pulsar coil. Have solenoid ordered.
You said that you are getting plenty of spark and gas but it's not firing;if you mean it's spinning over,firing through the spark plugs and getting gas into the cylinders but not cranking & continuing to run try doing a compression check and adjusting the valves(?).
big mule is offline   Reply With Quote
Unread 02-07-2010, 11:18 AM   #3
Not Yet Wild
 
Join Date: Jan 2009
Posts: 18
Default Re: not firing

that is correct. I checked spark plug fire it is good, it is getting gas. I set the valves to spec also.
shoprocket is offline   Reply With Quote
Unread 02-07-2010, 11:55 AM   #4
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,985
Default Re: not firing

We had a guy a week ago found a push rod had jumped, I assume you looked at all of the valve train when you had the rocker cover off.
DOOmsman is offline   Reply With Quote
Unread 02-07-2010, 01:22 PM   #5
Not Yet Wild
 
Join Date: Jan 2009
Posts: 18
Default Re: not firing

yes, everything looked fine. Quick run down- voltage is good, spark is good, gas flow is good, engine turning over fine but not trying to start. Put on a performance muffler, wondering if carb jet needs changed because of less restricted air flow?
shoprocket is offline   Reply With Quote
Unread 02-07-2010, 02:45 PM   #6
Gone Wild
E-Z-GO
 
Join Date: Jun 2008
Location: LINWOOD, MI
Posts: 1,362
Default Re: not firing

Quote:
Originally Posted by shoprocket View Post
yes, everything looked fine. Quick run down- voltage is good, spark is good, gas flow is good, engine turning over fine but not trying to start. Put on a performance muffler, wondering if carb jet needs changed because of less restricted air flow?
I didn't have to mess with the jeting.
Radicalgolfcarts is offline   Reply With Quote
Unread 02-07-2010, 05:13 PM   #7
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,985
Default Re: not firing

Try a little gas in the plug holes and see if it pops.
DOOmsman is offline   Reply With Quote
Unread 02-07-2010, 08:15 PM   #8
Gone Wild
 
chardonite's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: Chardon Ohio
Posts: 257
Default Re: not firing

Do a compression check..
chardonite is offline   Reply With Quote
Unread 02-07-2010, 08:58 PM   #9
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: not firing

Quote:
Originally Posted by chardonite View Post
Do a compression check..
Yep, if you have fire and fuel you just need compression.
was the engine running and you are just fixing it up? just rebuilt? got it that way and just trying to get it to work? what's the story and why all the new parts?
I guess it can be possible it jumped out of time. usually they break the belt and don't jump time but I belive there was one guy that said his jumped time. reguardless if the timings not right it probably won't start.
ruredy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
295 Robin firing once. Gas EZGO
G1 gets fuel and is firing Gas Yamaha
Back firing Gas EZGO
96 ezgo back firing Gas EZGO
Back Firing Gas EZGO


All times are GMT -5. The time now is 05:03 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.