lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-08-2010, 08:49 PM   #11
Doin' the Wild Thang
 
ez go go's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Greenville, AL
Posts: 1,063
Default Re: 99 EZ Go gas runs 10 minutes and sputters afterwards

If you got it fixed for just a 20 then don't ask questions.... Just hop in the cart, have a beer and think " Oh yeah, I'm good ". LOL
ez go go is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-08-2010, 09:40 PM   #12
Gone Crazy
 
Join Date: Jan 2007
Location: Chesterfield, Va
Posts: 5,100
Default Re: 99 EZ Go gas runs 10 minutes and sputters afterwards

Now it's time to DTPOI!!!
crash12888 is offline   Reply With Quote
Unread 06-11-2010, 04:42 PM   #13
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2010
Location: Lakeland, Florida
Posts: 17
Default Re: (Updated)99 EZ Go gas runs 10 minutes and sputters afterwards

Guys,
I need help again here. It appears the problem has NOT been resolved now as it started doing it again. Could it possibly be due to fuel as it still appears it is starving for fuel and the newly installed fuel filter have very little fuel. Could the fuel pump be bad. Another thing to note is this thing is VERY hot after riding for 30-45 minutes or so. Is that normal as my other EZ Go gas did not seem to run that hot. Any advice would be appreciated.
Thanks,
Kevin

Seth
Adams
Racing

Last edited by Sardad5; 06-11-2010 at 04:43 PM.. Reason: Need to add more info
Sardad5 is offline   Reply With Quote
Unread 06-16-2010, 01:45 PM   #14
Gone Wild
 
wingnut2000's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Georgia
Posts: 291
Default Re: 99 EZ Go gas runs 10 minutes and sputters afterwards

got cart back from mechanic and seems to be running good. had to get a new fuel pump. wish i would have known it was that. i coulda replaced in two minutes. They also said i need a new clutch which is ok because they said it would still run awhile with the one i got and i will get a performance clutch one day
wingnut2000 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Runs 10 minutes then shuts off, wait 5 then runs again... Electric EZGO
Reverse...runs awesome Forward..runs bad Gas EZGO
Runs 15 minutes then abrupt slowdown Electric EZGO
Charge 4 Hrs-Runs 30 Minutes Electric EZGO


All times are GMT -5. The time now is 02:41 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.